Cross-site scripting (XSS) vulnerability in the Build Failure Analyzer plugin before…
Priority LOW 19CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the Build Failure Analyzer plugin before 1.5.1 for Jenkins allows remote authenticated users to inject arbitrary web script or HTML via unspecified vectors.
Why it matters now
EPSS 0.00967 62nd percentileScored 2026-11-07
Fix Fixed com.sonyericsson.jenkins.plugins.bfa:build-failure-analyzer (Maven): 1.5.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | com.sonyericsson.jenkins.plugins.bfa:build-failure-analyzer (Maven) | before 1.5.1 | 1.5.1 | Patch available | GHSA-h52h-972r-68mh |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- com.sonyericsson.jenkins.plugins.bfa:build-failure-analyzer (Maven) Vendor— Affected before 1.5.1 Fixed in 1.5.1 Patch available GHSA-h52h-972r-68mh
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jenkins-ci:build_failure_analyzer:*:-:*:*:*:cloudbees_jenkins:*:* | up to 1.5.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:build_failure_analyzer:1.2.0:-:*:*:*:cloudbees_jenkins:*:* | 1.2.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:build_failure_analyzer:1.3.0:-:*:*:*:cloudbees_jenkins:*:* | 1.3.0 | Vulnerable | Jenkins-ci |
| cpe:2.3:a:jenkins-ci:build_failure_analyzer:1.4.0:-:*:*:*:cloudbees_jenkins:*:* | 1.4.0 | Vulnerable | Jenkins-ci |
- cpe:2.3:a:jenkins-ci:build_failure_analyzer:*:-:*:*:*:cloudbees_jenkins:*:* Versions up to 1.5.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:build_failure_analyzer:1.2.0:-:*:*:*:cloudbees_jenkins:*:* Versions 1.2.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:build_failure_analyzer:1.3.0:-:*:*:*:cloudbees_jenkins:*:* Versions 1.3.0 Vulnerable ·Jenkins-ci
- cpe:2.3:a:jenkins-ci:build_failure_analyzer:1.4.0:-:*:*:*:cloudbees_jenkins:*:* Versions 1.4.0 Vulnerable ·Jenkins-ci
Remediation
- Fix · GHSA-h52h-972r-68mh com.sonyericsson.jenkins.plugins.bfa:build-failure-analyzer (Maven) Fixed in 1.5.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 2 products
- OpenShift Enterprise 1
- Red Hat OpenShift Enterprise 2
Timeline
- 2026-10-02 Threatist record created from CVE-2013-6374
- 2026-10-03 Alias added: GHSA-h52h-972r-68mh
References
Advisory 2
Sources
- CVE-2013-6374 · CVE Program
- CVE-2013-6374 · NVD
- FIRST EPSS
- GHSA-h52h-972r-68mh · GitHub Advisory Database · CC BY 4.0
- CVE-2013-6374 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences