Cross-site scripting (XSS) vulnerability in the simple_format helper in…
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the simple_format helper in actionpack/lib/action_view/helpers/text_helper.rb in Ruby on Rails 4.x before 4.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted HTML attribute.
Why it matters now
EPSS 0.01963 80th percentileScored 2026-11-07
Fix Fixed actionpack (RubyGems): 4.0.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | actionpack (RubyGems) | 4.0.0 to before 4.0.2 | 4.0.2 | Patch available | GHSA-w37c-q653-qg95 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- actionpack (RubyGems) Vendor— Affected 4.0.0 to before 4.0.2 Fixed in 4.0.2 Patch available GHSA-w37c-q653-qg95
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rubyonrails:rails:*:-:*:*:*:*:*:* | up to 4.0.1 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:4.0.0:-:*:*:*:*:*:* | 4.0.0 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:4.0.0:beta:*:*:*:*:*:* | 4.0.0 beta | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:4.0.0:rc1:*:*:*:*:*:* | 4.0.0 rc1 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:4.0.0:rc2:*:*:*:*:*:* | 4.0.0 rc2 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:4.0.1:rc1:*:*:*:*:*:* | 4.0.1 rc1 | Vulnerable | Rails |
- cpe:2.3:a:rubyonrails:rails:*:-:*:*:*:*:*:* Versions up to 4.0.1 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:4.0.0:-:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:4.0.0:beta:*:*:*:*:*:* Versions 4.0.0 beta Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:4.0.0:rc1:*:*:*:*:*:* Versions 4.0.0 rc1 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:4.0.0:rc2:*:*:*:*:*:* Versions 4.0.0 rc2 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:4.0.1:rc1:*:*:*:*:*:* Versions 4.0.1 rc1 Vulnerable ·Rails
Remediation
- Fix · GHSA-w37c-q653-qg95 actionpack (RubyGems) Fixed in 4.0.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 7 products
- CloudForms Management Engine 5
- OpenShift Enterprise 1
- Red Hat OpenStack Platform 3
- Red Hat OpenStack Platform 4
- Red Hat Satellite 6
- Red Hat Software Collections
- Red Hat Subscription Asset Manager
Timeline
- 2026-10-02 Threatist record created from CVE-2013-6416
- 2026-10-03 Alias added: GHSA-w37c-q653-qg95
References
Other 8
- http://weblog.rubyonrails.org/2013/12/3/Rails_3_2_16_and_4_0_2_have_been_released/
- [ruby-security-ann] 20131203 [CVE-2013-6416] XSS Vulnerability in simple_format helper
- https://github.com/rails/rails/commit/4b4f5847f64f81c961625e647711ef9f6ad1a454
- https://github.com/rails/rails
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/actionpack/CVE-2013-6416.yml
- https://groups.google.com/forum/#!topic/ruby-security-ann/5ZI1-H5OoIM
- https://web.archive.org/web/20200228165109/http://www.securityfocus.com/bid/64071
- http://weblog.rubyonrails.org/2013/12/3/Rails_3_2_16_and_4_0_2_have_been_released
More Rails vulnerabilities
- TI-2014-00124 Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the… KEVCVSS 3.1HIGH 7.5
- TI-2019-03828 Path traversal in Rails https://github.com/rails/rails KEVCVSS 3.1HIGH 7.5
- TI-2016-00672 Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.1, 4.0.x… KEVCVSS 3.1HIGH 7.5
- TI-2019-03830 Command injection in Rails https://github.com/rails/rails CVSS 3.1CRITICAL 9.8
- TI-2020-06581 Code injection in https://github.com/rails/rails CVSS 3.1HIGH 8.8
- TI-2013-00091 active_support/core_ext/hash/conversions.rb in Ruby on Rails before 2.3.15, 3.0.x before… CVSS 2.0HIGH 7.5
Sources
- CVE-2013-6416 · CVE Program
- CVE-2013-6416 · NVD
- FIRST EPSS
- GHSA-w37c-q653-qg95 · GitHub Advisory Database · CC BY 4.0
- CVE-2013-6416 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences