Cross-site scripting in Wikimedia Foundation MediaWiki
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in MediaWiki 1.19.9 before 1.19.10, 1.2x before 1.21.4, and 1.22.x before 1.22.1 allows remote attackers to inject arbitrary web script or HTML via unspecified CSS values.
Why it matters now
EPSS 0.01078 65th percentileScored 2026-11-07
Fix Fixed MediaWiki (Wikimedia Foundation): 1.19.10, 1.21.4, 1.22.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Wikimedia Foundation | MediaWiki | 1.19.9 to before 1.19.10; 1.2x to before 1.21.4; 1.22 to before 1.22.1 | 1.19.10, 1.21.4, 1.22.1 | Patch available | CNA |
- MediaWiki VendorWikimedia Foundation Affected 1.19.9 to before 1.19.10; 1.2x to before 1.21.4; 1.22 to before 1.22.1 Fixed in 1.19.10, 1.21.4, 1.22.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* | 1.19.9 to before 1.19.10; 1.20.0 to before 1.21.4; 1.22.0 to before 1.22.1 | Vulnerable | mediawiki |
- cpe:2.3:a:mediawiki:mediawiki:*:*:*:*:*:*:*:* Versions 1.19.9 to before 1.19.10; 1.20.0 to before 1.21.4; 1.22.0 to before 1.22.1 Vulnerable ·mediawiki
Remediation
- Fix · CNA MediaWiki (Wikimedia Foundation) Fixed in 1.19.10, 1.21.4, 1.22.1
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2013-6451
- 2026-10-03 Alias added: GHSA-423m-g5gq-97wq
References
More Wikimedia Foundation vulnerabilities
- TI-2025-11006 The compare API module breaks Extension:Lockdown CVSS 4.0CRITICAL 10.0
- TI-2024-32110 Backticks can allow the usage of not-allowed SQL functions CVSS 4.0HIGH 8.8
- TI-2026-65500 Unauthenticated SQL injection in UserPageViewTracker via filterusers and ignoreusers parameters CVSS 3.1HIGH 7.5
- TI-2026-64588 DataTransfer depends on phpspreadsheet version vulnerable to CVE-2026-59933 (XLS/OLE memory exhaustion) CVSS 3.1HIGH 7.5
- TI-2026-42112 SQLi in Cargo extension via year range filter CVSS 4.0MEDIUM 6.9
- TI-2026-42110 Stored XSS through Cargo's map format CVSS 4.0MEDIUM 6.9
Sources
- CVE-2013-6451 · CVE Program
- CVE-2013-6451 · NVD
- FIRST EPSS
- GHSA-423m-g5gq-97wq · GitHub Advisory Database · CC BY 4.0
- CVE-2013-6451 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences