Cross-site scripting (XSS) vulnerability in the will_paginate gem before 3.0.5 for Ruby…
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Partial Red Hat: 2 fixed, 4 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the will_paginate gem before 3.0.5 for Ruby allows remote attackers to inject arbitrary web script or HTML via vectors involving generated pagination links.
Why it matters now
EPSS 0.02209 82nd percentileScored 2026-11-07
Fix Partial will_paginate (RubyGems): 3.0.5Red Hat: 1 advisoryRed Hat: 2 fixed, 4 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | will_paginate (RubyGems) | before 3.0.5 | 3.0.5 | Patch available | GHSA-8r6h-7x9g-xmw9 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- will_paginate (RubyGems) Vendor— Affected before 3.0.5 Fixed in 3.0.5 Patch available GHSA-8r6h-7x9g-xmw9
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:mislav_marohnic:will_paginate:*:-:-:*:-:ruby:*:* | up to 3.0.4 | Vulnerable | Mislav Marohnic |
| cpe:2.3:a:mislav_marohnic:will_paginate:3.0:-:-:*:-:ruby:*:* | 3.0 | Vulnerable | Mislav Marohnic |
| cpe:2.3:a:mislav_marohnic:will_paginate:3.0.1:-:-:*:-:ruby:*:* | 3.0.1 | Vulnerable | Mislav Marohnic |
| cpe:2.3:a:mislav_marohnic:will_paginate:3.0.2:-:-:*:-:ruby:*:* | 3.0.2 | Vulnerable | Mislav Marohnic |
| cpe:2.3:a:mislav_marohnic:will_paginate:3.0.3:-:-:*:-:ruby:*:* | 3.0.3 | Vulnerable | Mislav Marohnic |
- cpe:2.3:a:mislav_marohnic:will_paginate:*:-:-:*:-:ruby:*:* Versions up to 3.0.4 Vulnerable ·Mislav Marohnic
- cpe:2.3:a:mislav_marohnic:will_paginate:3.0:-:-:*:-:ruby:*:* Versions 3.0 Vulnerable ·Mislav Marohnic
- cpe:2.3:a:mislav_marohnic:will_paginate:3.0.1:-:-:*:-:ruby:*:* Versions 3.0.1 Vulnerable ·Mislav Marohnic
- cpe:2.3:a:mislav_marohnic:will_paginate:3.0.2:-:-:*:-:ruby:*:* Versions 3.0.2 Vulnerable ·Mislav Marohnic
- cpe:2.3:a:mislav_marohnic:will_paginate:3.0.3:-:-:*:-:ruby:*:* Versions 3.0.3 Vulnerable ·Mislav Marohnic
Remediation
- Fix · GHSA-8r6h-7x9g-xmw9 will_paginate (RubyGems) Fixed in 3.0.5 Advisory →
Red Hat 1 advisory
- RHSA-2018:0336 Released 2018-02-21 · Red Hat rating ImportantSatellite 6.3 security, bug fix, and enhancement update
- Red Hat Satellite 6.3 candlepin-2.1.14-1.el7, candlepin-selinux-2.1.14-1.el7, foreman-1.15.6.34-1.el7sat +47
- Red Hat Satellite Capsule 6.3 foreman-1.15.6.34-1.el7sat, foreman-bootloaders-redhat-201801241201-2.el7sat, foreman-bootloaders-redhat-tftpboot-201801241201-2.el7sat +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenStack Foreman | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux OpenStack Platform 6 (Juno) Installer | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 3 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 4 | Affected | No fix planned: Will not fix |
| Red Hat Satellite 6.3 | Fixed | RHSA-2018:0336 |
| Red Hat Satellite Capsule 6.3 | Fixed | RHSA-2018:0336 |
Timeline
- 2026-10-02 Threatist record created from CVE-2013-6459
- 2026-10-03 Alias added: GHSA-8r6h-7x9g-xmw9
References
Sources
- CVE-2013-6459 · CVE Program
- CVE-2013-6459 · NVD
- FIRST EPSS
- GHSA-8r6h-7x9g-xmw9 · GitHub Advisory Database · CC BY 4.0
- CVE-2013-6459 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences