Transifex command-line client before 0.10 does not validate X.509 certificates for data…
Priority LOW 22CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- —
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub.
Summary
Transifex command-line client before 0.10 does not validate X.509 certificates for data transfer connections, which allows man-in-the-middle attackers to spoof a Transifex server via an arbitrary certificate. NOTE: this vulnerability exists because of an incomplete fix for CVE-2013-2073.
Why it matters now
EPSS 0.00832 57th percentileScored 2026-11-07
Fix Fixed transifex-client (PyPI): 0.10
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | transifex-client (PyPI) | before 0.10 | 0.10 | Patch available | GHSA-jf99-2rj4-jxrm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- transifex-client (PyPI) Vendor— Affected before 0.10 Fixed in 0.10 Patch available GHSA-jf99-2rj4-jxrm
CPE configurations NVD · 9
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:transifex:transifex:*:*:*:*:*:*:*:* | up to 0.9 | Vulnerable | Transifex |
| cpe:2.3:a:transifex:transifex:0.1:*:*:*:*:*:*:* | 0.1 | Vulnerable | Transifex |
| cpe:2.3:a:transifex:transifex:0.2:*:*:*:*:*:*:* | 0.2 | Vulnerable | Transifex |
| cpe:2.3:a:transifex:transifex:0.3:*:*:*:*:*:*:* | 0.3 | Vulnerable | Transifex |
| cpe:2.3:a:transifex:transifex:0.4:*:*:*:*:*:*:* | 0.4 | Vulnerable | Transifex |
| cpe:2.3:a:transifex:transifex:0.5:*:*:*:*:*:*:* | 0.5 | Vulnerable | Transifex |
| cpe:2.3:a:transifex:transifex:0.6:*:*:*:*:*:*:* | 0.6 | Vulnerable | Transifex |
| cpe:2.3:a:transifex:transifex:0.7:*:*:*:*:*:*:* | 0.7 | Vulnerable | Transifex |
| cpe:2.3:a:transifex:transifex:0.8:*:*:*:*:*:*:* | 0.8 | Vulnerable | Transifex |
- cpe:2.3:a:transifex:transifex:*:*:*:*:*:*:*:* Versions up to 0.9 Vulnerable ·Transifex
- cpe:2.3:a:transifex:transifex:0.1:*:*:*:*:*:*:* Versions 0.1 Vulnerable ·Transifex
- cpe:2.3:a:transifex:transifex:0.2:*:*:*:*:*:*:* Versions 0.2 Vulnerable ·Transifex
- cpe:2.3:a:transifex:transifex:0.3:*:*:*:*:*:*:* Versions 0.3 Vulnerable ·Transifex
- cpe:2.3:a:transifex:transifex:0.4:*:*:*:*:*:*:* Versions 0.4 Vulnerable ·Transifex
- cpe:2.3:a:transifex:transifex:0.5:*:*:*:*:*:*:* Versions 0.5 Vulnerable ·Transifex
- cpe:2.3:a:transifex:transifex:0.6:*:*:*:*:*:*:* Versions 0.6 Vulnerable ·Transifex
- cpe:2.3:a:transifex:transifex:0.7:*:*:*:*:*:*:* Versions 0.7 Vulnerable ·Transifex
- cpe:2.3:a:transifex:transifex:0.8:*:*:*:*:*:*:* Versions 0.8 Vulnerable ·Transifex
Remediation
- Fix · GHSA-jf99-2rj4-jxrm transifex-client (PyPI) Fixed in 0.10 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2013-7110
- 2026-10-03 Alias added: GHSA-jf99-2rj4-jxrm
References
Other 6
- [oss-security] 20131213 Re: CVE-2013-2073 transifex-client: Does not validate HTTPS server certificate (fixed in transifex-client v0.9)
- https://github.com/transifex/transifex-client/issues/42
- [oss-security] 20131215 Re: CVE-2013-2073 transifex-client: Does not validate HTTPS server certificate (fixed in transifex-client v0.9)
- https://github.com/transifex/transifex-client/commit/e0d1f8b38ec1a24e2999d63420554d8393206f58
- https://github.com/pypa/advisory-database/tree/main/vulns/transifex-client/PYSEC-2014-72.yaml
- https://github.com/transifex/transifex-client
More Transifex vulnerabilities
- TI-2013-01844 Transifex command-line client before 0.9 does not validate X.509 certificates, which… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2013-7110 · CVE Program
- CVE-2013-7110 · NVD
- FIRST EPSS
- GHSA-jf99-2rj4-jxrm · GitHub Advisory Database · CC BY 4.0
- CVE-2013-7110 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences