node-connect before 2.8.1 has XSS in the Sencha Labs Connect middleware
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
node-connect before 2.8.1 has XSS in the Sencha Labs Connect middleware
Why it matters now
EPSS 0.01417 72nd percentileScored 2026-11-07
Fix Partial —: 2.8.1connect (npm): 2.8.1Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | before 2.8.1 | 2.8.1 | Patch available | CNA |
| — | connect (npm) | before 2.8.1 | 2.8.1 | Patch available | GHSA-3fw8-66wf-pr7m |
- — Vendor— Affected before 2.8.1 Fixed in 2.8.1 Patch available CNA
- connect (npm) Vendor— Affected before 2.8.1 Fixed in 2.8.1 Patch available GHSA-3fw8-66wf-pr7m
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:redhat:openshift:2.0:*:*:*:enterprise:*:*:* | 2.0 | Vulnerable | Red Hat |
| cpe:2.3:a:sencha:connect:*:*:*:*:*:node.js:*:* | before 2.8.1 | Vulnerable | Sencha |
| cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:* | 13.1 | Vulnerable | openSUSE |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:redhat:openshift:2.0:*:*:*:enterprise:*:*:* Versions 2.0 Vulnerable ·Red Hat
- cpe:2.3:a:sencha:connect:*:*:*:*:*:node.js:*:* Versions before 2.8.1 Vulnerable ·Sencha
- cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:* Versions 13.1 Vulnerable ·openSUSE
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA — Fixed in 2.8.1
- Fix · GHSA-3fw8-66wf-pr7m connect (npm) Fixed in 2.8.1 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Enterprise 2 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2013-7370
- 2026-10-03 Alias added: GHSA-3fw8-66wf-pr7m
References
Advisory 6
- https://nodesecurity.io/advisories/methodOverride_Middleware_Reflected_Cross-Site_Scripting
- https://security-tracker.debian.org/tracker/CVE-2013-7370
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2013-7370
- https://access.redhat.com/security/cve/cve-2013-7370
- http://www.openwall.com/lists/oss-security/2014/05/13/1
- https://nvd.nist.gov/vuln/detail/CVE-2013-7370
Other 5
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2013-7370
- https://github.com/senchalabs/connect/issues/831
- https://github.com/senchalabs/connect/commit/126187c4e12162e231b87350740045e5bb06e93a
- https://github.com/senchalabs/connect/commit/277e5aad6a95d00f55571a9a0e11f2fa190d8135
- https://www.npmjs.com/advisories/3
Sources
- CVE-2013-7370 · CVE Program
- CVE-2013-7370 · NVD
- FIRST EPSS
- GHSA-3fw8-66wf-pr7m · GitHub Advisory Database · CC BY 4.0
- CVE-2013-7370 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences