Cross-site scripting in node-connect
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
node-connects before 2.8.2 has cross site scripting in Sencha Labs Connect middleware (vulnerability due to incomplete fix for CVE-2013-7370)
Why it matters now
EPSS 0.01435 73rd percentileScored 2026-11-07
Fix Fixed node-connect (node-connect): 2.8.2connect (npm): 2.8.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| node-connect | node-connect | before 2.8.2 | 2.8.2 | Patch available | CNA |
| — | connect (npm) | before 2.8.2 | 2.8.2 | Patch available | GHSA-6w62-83g6-rfhj |
- node-connect Vendornode-connect Affected before 2.8.2 Fixed in 2.8.2 Patch available CNA
- connect (npm) Vendor— Affected before 2.8.2 Fixed in 2.8.2 Patch available GHSA-6w62-83g6-rfhj
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sencha:connect:*:*:*:*:*:node.js:*:* | before 2.8.2 | Vulnerable | Sencha |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:sencha:connect:*:*:*:*:*:node.js:*:* Versions before 2.8.2 Vulnerable ·Sencha
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA node-connect (node-connect) Fixed in 2.8.2
- Fix · GHSA-6w62-83g6-rfhj connect (npm) Fixed in 2.8.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2013-7371
- 2026-10-03 Alias added: GHSA-6w62-83g6-rfhj
References
Advisory 5
- https://nodesecurity.io/advisories/methodOverride_Middleware_Reflected_Cross-Site_Scripting
- http://www.openwall.com/lists/oss-security/2014/05/13/1
- https://security-tracker.debian.org/tracker/CVE-2013-7371
- https://access.redhat.com/security/cve/cve-2013-7371
- https://nvd.nist.gov/vuln/detail/CVE-2013-7371
Sources
- CVE-2013-7371 · CVE Program
- CVE-2013-7371 · NVD
- FIRST EPSS
- GHSA-6w62-83g6-rfhj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences