libnotify before 1.0.4 for Node.js allows remote attackers to execute arbitrary commands…
Priority MEDIUM 47CWE-74Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
libnotify before 1.0.4 for Node.js allows remote attackers to execute arbitrary commands via unspecified characters in a call to libnotify.notify.
Why it matters now
EPSS 0.02685 85th percentileScored 2026-11-07
Fix Fixed libnotify (npm): 1.0.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | libnotify (npm) | before 1.0.4 | 1.0.4 | Patch available | GHSA-6898-wx94-8jq8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- libnotify (npm) Vendor— Affected before 1.0.4 Fixed in 1.0.4 Patch available GHSA-6898-wx94-8jq8
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:libnotify_project:libnotify:*:*:*:*:*:node.js:*:* | before 1.0.4 | Vulnerable | Libnotify Project |
- cpe:2.3:a:libnotify_project:libnotify:*:*:*:*:*:node.js:*:* Versions before 1.0.4 Vulnerable ·Libnotify Project
Remediation
- Fix · GHSA-6898-wx94-8jq8 libnotify (npm) Fixed in 1.0.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2013-7381
- 2026-10-03 Alias added: GHSA-6898-wx94-8jq8
References
Advisory 3
Sources
- CVE-2013-7381 · CVE Program
- CVE-2013-7381 · NVD
- FIRST EPSS
- GHSA-6898-wx94-8jq8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences