SQL injection vulnerability in…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
SQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql/cast.rb in Active Record in Ruby on Rails 4.0.x before 4.0.3, and 4.1.0.beta1, when PostgreSQL is used, allows remote attackers to execute "add data" SQL commands via vectors involving \ (backslash) characters that are not properly handled in operations on array columns.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | activerecord (RubyGems) | 4.0.0 to before 4.0.3 | 4.0.3 | Patch available | GHSA-hqf9-rc9j-5fmj |
| — | activerecord (RubyGems) | 4.1.0.beta1 to before 4.1.0.beta2 | 4.1.0.beta2 | Patch available | GHSA-hqf9-rc9j-5fmj |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- activerecord (RubyGems) Vendor— Affected 4.0.0 to before 4.0.3 Fixed in 4.0.3 Patch available GHSA-hqf9-rc9j-5fmj
- activerecord (RubyGems) Vendor— Affected 4.1.0.beta1 to before 4.1.0.beta2 Fixed in 4.1.0.beta2 Patch available GHSA-hqf9-rc9j-5fmj
CPE configurations NVD · 11
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rubyonrails:rails:4.0.0:-:*:*:*:*:*:* | 4.0.0 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:4.0.0:beta:*:*:*:*:*:* | 4.0.0 beta | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:4.0.0:rc1:*:*:*:*:*:* | 4.0.0 rc1 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:4.0.0:rc2:*:*:*:*:*:* | 4.0.0 rc2 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:4.0.1:-:*:*:*:*:*:* | 4.0.1 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:4.0.1:rc1:*:*:*:*:*:* | 4.0.1 rc1 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:4.0.1:rc2:*:*:*:*:*:* | 4.0.1 rc2 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:4.0.1:rc3:*:*:*:*:*:* | 4.0.1 rc3 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:4.0.1:rc4:*:*:*:*:*:* | 4.0.1 rc4 | Vulnerable | Rails |
| cpe:2.3:a:rubyonrails:rails:4.0.2:*:*:*:*:*:*:* | 4.0.2 | Vulnerable | Rails |
- cpe:2.3:a:rubyonrails:rails:4.0.0:-:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:4.0.0:beta:*:*:*:*:*:* Versions 4.0.0 beta Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:4.0.0:rc1:*:*:*:*:*:* Versions 4.0.0 rc1 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:4.0.0:rc2:*:*:*:*:*:* Versions 4.0.0 rc2 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:4.0.1:-:*:*:*:*:*:* Versions 4.0.1 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:4.0.1:rc1:*:*:*:*:*:* Versions 4.0.1 rc1 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:4.0.1:rc2:*:*:*:*:*:* Versions 4.0.1 rc2 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:4.0.1:rc3:*:*:*:*:*:* Versions 4.0.1 rc3 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:4.0.1:rc4:*:*:*:*:*:* Versions 4.0.1 rc4 Vulnerable ·Rails
- cpe:2.3:a:rubyonrails:rails:4.0.2:*:*:*:*:*:*:* Versions 4.0.2 Vulnerable ·Rails
Remediation
- Fix · GHSA-hqf9-rc9j-5fmj activerecord (RubyGems) Fixed in 4.0.3 Advisory →
- Fix · GHSA-hqf9-rc9j-5fmj activerecord (RubyGems) Fixed in 4.1.0.beta2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 7 products
- CloudForms Management Engine 5
- OpenShift Enterprise 1
- Red Hat OpenStack Platform 3
- Red Hat OpenStack Platform 4
- Red Hat Satellite 6
- Red Hat Software Collections
- Red Hat Subscription Asset Manager
Timeline
- 2026-10-02 Threatist record created from CVE-2014-0080
- 2026-10-03 Alias added: GHSA-hqf9-rc9j-5fmj
References
Advisory 2
Other 5
- [rubyonrails-security] 20140218 Data Injection Vulnerability in Active Record (CVE-2014-0080)
- [oss-security] 20140218 Data Injection Vulnerability in Active Record (CVE-2014-0080)
- https://github.com/rails/rails/tree/main/activerecord
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/activerecord/CVE-2014-0080.yml
- https://web.archive.org/web/20210301004521/https://groups.google.com/forum/message/raw?msg=rubyonrails-security/Wu96YkTUR6s/pPLBMZrlwvYJ
More Rails vulnerabilities
- TI-2014-00124 Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the… KEVCVSS 3.1HIGH 7.5
- TI-2019-03828 Path traversal in Rails https://github.com/rails/rails KEVCVSS 3.1HIGH 7.5
- TI-2016-00672 Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.1, 4.0.x… KEVCVSS 3.1HIGH 7.5
- TI-2019-03830 Command injection in Rails https://github.com/rails/rails CVSS 3.1CRITICAL 9.8
- TI-2020-06581 Code injection in https://github.com/rails/rails CVSS 3.1HIGH 8.8
- TI-2013-00091 active_support/core_ext/hash/conversions.rb in Ruby on Rails before 2.3.15, 3.0.x before… CVSS 2.0HIGH 7.5
Sources
- CVE-2014-0080 · CVE Program
- CVE-2014-0080 · NVD
- FIRST EPSS
- GHSA-hqf9-rc9j-5fmj · GitHub Advisory Database · CC BY 4.0
- CVE-2014-0080 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences