The Ruby net-ldap gem before 0.11 uses a weak salt when generating SSHA passwords.
Priority LOW 25CWE-916Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
The Ruby net-ldap gem before 0.11 uses a weak salt when generating SSHA passwords.
Why it matters now
EPSS 0.00275 20th percentileScored 2026-11-07
Fix Fixed net-ldap (RubyGems): 0.16.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ruby-net-ldap | ruby-net-ldap | 0.16.2 | — | No fix listed | CNA |
| — | net-ldap (RubyGems) | before 0.16.2 | 0.16.2 | Patch available | GHSA-qwgm-mxm4-3q2c |
- ruby-net-ldap Vendorruby-net-ldap Affected 0.16.2 Fixed in — No fix listed CNA
- net-ldap (RubyGems) Vendor— Affected before 0.16.2 Fixed in 0.16.2 Patch available GHSA-qwgm-mxm4-3q2c
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:net-ldap_project:net-ldap:*:*:*:*:*:ruby:*:* | before 0.16.2 | Vulnerable | Net-ldap Project |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:net-ldap_project:net-ldap:*:*:*:*:*:ruby:*:* Versions before 0.16.2 Vulnerable ·Net-ldap Project
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-qwgm-mxm4-3q2c net-ldap (RubyGems) Fixed in 0.16.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 5 products
- CloudForms Management Engine 5
- Red Hat OpenStack Platform 3
- Red Hat OpenStack Platform 4
- Red Hat Satellite 6
- Red Hat Subscription Asset Manager
Timeline
- 2026-10-02 Threatist record created from CVE-2014-0083
- 2026-10-03 Alias added: GHSA-qwgm-mxm4-3q2c
References
Patch 2
Advisory 3
Sources
- CVE-2014-0083 · CVE Program
- CVE-2014-0083 · NVD
- FIRST EPSS
- GHSA-qwgm-mxm4-3q2c · GitHub Advisory Database · CC BY 4.0
- CVE-2014-0083 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences