Improper certificate validation in fence-agents
Priority LOW 28CWE-295Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-295.
Summary
In fence-agents before 4.0.17 does not verify remote SSL certificates in the fence_cisco_ucs.py script which can potentially allow for man-in-the-middle attackers to spoof SSL servers via arbitrary SSL certificates.
Why it matters now
EPSS 0.00834 57th percentileScored 2026-11-07
Fix Partial fence-agents (fence-agents): 4.0.17Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| fence-agents | fence-agents | before 4.0.17 | 4.0.17 | Patch available | CNA |
- fence-agents Vendorfence-agents Affected before 4.0.17 Fixed in 4.0.17 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:clusterlabs:fence-agents:*:*:*:*:*:*:*:* | before 4.0.17 | Vulnerable | ClusterLabs |
- cpe:2.3:a:clusterlabs:fence-agents:*:*:*:*:*:*:*:* Versions before 4.0.17 Vulnerable ·ClusterLabs
Remediation
- Fix · CNA fence-agents (fence-agents) Fixed in 4.0.17
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
Not affected: 1 product
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2014-0104
- 2026-10-03 Alias added: GHSA-c77j-gxmx-7mxq
References
More ClusterLabs Fence-agents vulnerabilities
- TI-2019-07474 A flaw was discovered in fence-agents, prior to version 4.3.4, where using non-ASCII… CVSS 3.1MEDIUM 5.0
Sources
- CVE-2014-0104 · CVE Program
- CVE-2014-0104 · NVD
- FIRST EPSS
- GHSA-c77j-gxmx-7mxq · GitHub Advisory Database · CC BY 4.0
- CVE-2014-0104 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences