Cross-site scripting (XSS) vulnerability in the Horizon Orchestration dashboard in…
Priority LOW 22CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Partial Red Hat: 1 fixed, 1 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in the Horizon Orchestration dashboard in OpenStack Dashboard (aka Horizon) 2013.2 before 2013.2.4 and icehouse before icehouse-rc2 allows remote attackers to inject arbitrary web script or HTML via the description field of a Heat template.
Why it matters now
EPSS 0.01216 68th percentileScored 2026-11-07
Fix Partial horizon (PyPI): 2013.2.4Red Hat: 1 advisoryRed Hat: 1 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | horizon (PyPI) | 2013.2 to before 2013.2.4 | 2013.2.4 | Patch available | GHSA-cmg8-5c63-pg95 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- horizon (PyPI) Vendor— Affected 2013.2 to before 2013.2.4 Fixed in 2013.2.4 Patch available GHSA-cmg8-5c63-pg95
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openstack:horizon:2013.2:*:*:*:*:*:*:* | 2013.2 | Vulnerable | OpenStack |
| cpe:2.3:a:openstack:horizon:2013.2.1:*:*:*:*:*:*:* | 2013.2.1 | Vulnerable | OpenStack |
| cpe:2.3:a:openstack:horizon:2013.2.2:*:*:*:*:*:*:* | 2013.2.2 | Vulnerable | OpenStack |
| cpe:2.3:a:openstack:horizon:2013.2.3:*:*:*:*:*:*:* | 2013.2.3 | Vulnerable | OpenStack |
| cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:* | 13.1 | Vulnerable | openSUSE |
- cpe:2.3:a:openstack:horizon:2013.2:*:*:*:*:*:*:* Versions 2013.2 Vulnerable ·OpenStack
- cpe:2.3:a:openstack:horizon:2013.2.1:*:*:*:*:*:*:* Versions 2013.2.1 Vulnerable ·OpenStack
- cpe:2.3:a:openstack:horizon:2013.2.2:*:*:*:*:*:*:* Versions 2013.2.2 Vulnerable ·OpenStack
- cpe:2.3:a:openstack:horizon:2013.2.3:*:*:*:*:*:*:* Versions 2013.2.3 Vulnerable ·OpenStack
- cpe:2.3:o:opensuse:opensuse:13.1:*:*:*:*:*:*:* Versions 13.1 Vulnerable ·openSUSE
Remediation
- Fix · GHSA-cmg8-5c63-pg95 horizon (PyPI) Fixed in 2013.2.4 Advisory →
Red Hat 1 advisory
- RHSA-2014:0581 Released 2014-05-29 · Red Hat rating Lowpython-django-horizon security update
- Red Hat Enterprise Linux OpenStack Platform 4.0 openstack-dashboard-2013.2.3-1.el6ost, openstack-dashboard-theme-2013.2.3-1.el6ost, python-django-horizon-2013.2.3-1.el6ost +1
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenStack Platform 3 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux OpenStack Platform 4.0 | Fixed | RHSA-2014:0581 |
Timeline
- 2026-10-02 Threatist record created from CVE-2014-0157
- 2026-10-03 Alias added: GHSA-cmg8-5c63-pg95
References
Patch 1
Advisory 3
Sources
- CVE-2014-0157 · CVE Program
- CVE-2014-0157 · NVD
- FIRST EPSS
- GHSA-cmg8-5c63-pg95 · GitHub Advisory Database · CC BY 4.0
- CVE-2014-0157 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences