Improper certificate validation in ovirt-engine-sdk-python
Priority LOW 27CWE-295Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-295.
Summary
ovirt-engine-sdk-python before 3.4.0.7 and 3.5.0.4 does not verify that the hostname of the remote endpoint matches the Common Name (CN) or subjectAltName as specified by its x.509 certificate in a TLS/SSL session. This could allow man-in-the-middle attackers to spoof remote endpoints via an arbitrary valid certificate.
Why it matters now
EPSS 0.00413 35th percentileScored 2026-11-07
Fix Fixed ovirt-engine-sdk-python (PyPI): 3.4.0.7, 3.5.0.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ovirt-engine-sdk-python | ovirt-engine-sdk-python | before 3.4.0.7 and 3.5.0.4 | — | No fix listed | CNA |
| — | ovirt-engine-sdk-python (PyPI) | before 3.4.0.7 | 3.4.0.7 | Patch available | GHSA-wf9j-m9fv-92gq |
| — | ovirt-engine-sdk-python (PyPI) | 3.5.0.0 to before 3.5.0.4 | 3.5.0.4 | Patch available | GHSA-wf9j-m9fv-92gq |
- ovirt-engine-sdk-python Vendorovirt-engine-sdk-python Affected before 3.4.0.7 and 3.5.0.4 Fixed in — No fix listed CNA
- ovirt-engine-sdk-python (PyPI) Vendor— Affected before 3.4.0.7 Fixed in 3.4.0.7 Patch available GHSA-wf9j-m9fv-92gq
- ovirt-engine-sdk-python (PyPI) Vendor— Affected 3.5.0.0 to before 3.5.0.4 Fixed in 3.5.0.4 Patch available GHSA-wf9j-m9fv-92gq
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ovirt-engine-sdk-python_project:ovirt-engine-sdk-python:*:*:*:*:*:*:*:* | before 3.4.0.7; 3.5.0.0 to before 3.5.0.4 | Vulnerable | Ovirt-engine-sdk-python Project |
- cpe:2.3:a:ovirt-engine-sdk-python_project:ovirt-engine-sdk-python:*:*:*:*:*:*:*:* Versions before 3.4.0.7; 3.5.0.0 to before 3.5.0.4 Vulnerable ·Ovirt-engine-sdk-python Project
Remediation
- Fix · GHSA-wf9j-m9fv-92gq ovirt-engine-sdk-python (PyPI) Fixed in 3.4.0.7 Advisory →
- Fix · GHSA-wf9j-m9fv-92gq ovirt-engine-sdk-python (PyPI) Fixed in 3.5.0.4 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2014-0161
- 2026-10-03 Alias added: GHSA-wf9j-m9fv-92gq
References
Advisory 2
Sources
- CVE-2014-0161 · CVE Program
- CVE-2014-0161 · NVD
- FIRST EPSS
- GHSA-wf9j-m9fv-92gq · GitHub Advisory Database · CC BY 4.0
- CVE-2014-0161 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences