Cross-site request forgery (CSRF) vulnerability in Jolokia before 1.2.1 allows remote…
Priority LOW 31CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Tampering
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-352.
Summary
Cross-site request forgery (CSRF) vulnerability in Jolokia before 1.2.1 allows remote attackers to hijack the authentication of users for requests that execute MBeans methods via a crafted web page.
Why it matters now
EPSS 0.00739 54th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed org.jolokia:jolokia-core (Maven): 1.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jolokia:jolokia-core (Maven) | before 1.2.1 | 1.2.1 | Patch available | GHSA-fjhw-8222-g2hg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jolokia:jolokia-core (Maven) Vendor— Affected before 1.2.1 Fixed in 1.2.1 Patch available GHSA-fjhw-8222-g2hg
CPE configurations NVD · 14
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jolokia:jolokia:*:*:*:*:*:*:*:* | up to 1.2.0 | Vulnerable | jolokia |
| cpe:2.3:a:jolokia:jolokia:1.0.0:*:*:*:*:*:*:* | 1.0.0 | Vulnerable | jolokia |
| cpe:2.3:a:jolokia:jolokia:1.0.1:*:*:*:*:*:*:* | 1.0.1 | Vulnerable | jolokia |
| cpe:2.3:a:jolokia:jolokia:1.0.2:*:*:*:*:*:*:* | 1.0.2 | Vulnerable | jolokia |
| cpe:2.3:a:jolokia:jolokia:1.0.3:*:*:*:*:*:*:* | 1.0.3 | Vulnerable | jolokia |
| cpe:2.3:a:jolokia:jolokia:1.0.4:*:*:*:*:*:*:* | 1.0.4 | Vulnerable | jolokia |
| cpe:2.3:a:jolokia:jolokia:1.0.5:*:*:*:*:*:*:* | 1.0.5 | Vulnerable | jolokia |
| cpe:2.3:a:jolokia:jolokia:1.0.6:*:*:*:*:*:*:* | 1.0.6 | Vulnerable | jolokia |
| cpe:2.3:a:jolokia:jolokia:1.1.0:*:*:*:*:*:*:* | 1.1.0 | Vulnerable | jolokia |
| cpe:2.3:a:jolokia:jolokia:1.1.1:*:*:*:*:*:*:* | 1.1.1 | Vulnerable | jolokia |
- cpe:2.3:a:jolokia:jolokia:*:*:*:*:*:*:*:* Versions up to 1.2.0 Vulnerable ·jolokia
- cpe:2.3:a:jolokia:jolokia:1.0.0:*:*:*:*:*:*:* Versions 1.0.0 Vulnerable ·jolokia
- cpe:2.3:a:jolokia:jolokia:1.0.1:*:*:*:*:*:*:* Versions 1.0.1 Vulnerable ·jolokia
- cpe:2.3:a:jolokia:jolokia:1.0.2:*:*:*:*:*:*:* Versions 1.0.2 Vulnerable ·jolokia
- cpe:2.3:a:jolokia:jolokia:1.0.3:*:*:*:*:*:*:* Versions 1.0.3 Vulnerable ·jolokia
- cpe:2.3:a:jolokia:jolokia:1.0.4:*:*:*:*:*:*:* Versions 1.0.4 Vulnerable ·jolokia
- cpe:2.3:a:jolokia:jolokia:1.0.5:*:*:*:*:*:*:* Versions 1.0.5 Vulnerable ·jolokia
- cpe:2.3:a:jolokia:jolokia:1.0.6:*:*:*:*:*:*:* Versions 1.0.6 Vulnerable ·jolokia
- cpe:2.3:a:jolokia:jolokia:1.1.0:*:*:*:*:*:*:* Versions 1.1.0 Vulnerable ·jolokia
- cpe:2.3:a:jolokia:jolokia:1.1.1:*:*:*:*:*:*:* Versions 1.1.1 Vulnerable ·jolokia
Show 4 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jolokia:jolokia:1.1.2:*:*:*:*:*:*:* | 1.1.2 | Vulnerable | jolokia |
| cpe:2.3:a:jolokia:jolokia:1.1.3:*:*:*:*:*:*:* | 1.1.3 | Vulnerable | jolokia |
| cpe:2.3:a:jolokia:jolokia:1.1.4:*:*:*:*:*:*:* | 1.1.4 | Vulnerable | jolokia |
| cpe:2.3:a:jolokia:jolokia:1.1.5:*:*:*:*:*:*:* | 1.1.5 | Vulnerable | jolokia |
- cpe:2.3:a:jolokia:jolokia:1.1.2:*:*:*:*:*:*:* Versions 1.1.2 Vulnerable ·jolokia
- cpe:2.3:a:jolokia:jolokia:1.1.3:*:*:*:*:*:*:* Versions 1.1.3 Vulnerable ·jolokia
- cpe:2.3:a:jolokia:jolokia:1.1.4:*:*:*:*:*:*:* Versions 1.1.4 Vulnerable ·jolokia
- cpe:2.3:a:jolokia:jolokia:1.1.5:*:*:*:*:*:*:* Versions 1.1.5 Vulnerable ·jolokia
Remediation
- Fix · GHSA-fjhw-8222-g2hg org.jolokia:jolokia-core (Maven) Fixed in 1.2.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-0168
- 2026-10-03 Alias added: GHSA-fjhw-8222-g2hg
References
More Jolokia vulnerabilities
- TI-2018-15781 An XSS vulnerability exists in the Jolokia agent version 1.3.7 in the HTTP servlet that… CVSS 3.0MEDIUM 6.1
- TI-2018-07712 Improper input validation in jolokia CVSS 3.0HIGH 8.8
Sources
- CVE-2014-0168 · CVE Program
- CVE-2014-0168 · NVD
- FIRST EPSS
- GHSA-fjhw-8222-g2hg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences