Apache Hive before 0.13.1, when in SQL standards based authorization mode, does not…
Priority LOW 23CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
Apache Hive before 0.13.1, when in SQL standards based authorization mode, does not properly check the file permissions for (1) import and (2) export statements, which allows remote authenticated users to obtain sensitive information via a crafted URI.
Why it matters now
EPSS 0.03498 89th percentileScored 2026-11-07
Fix Fixed org.apache.hive:hive (Maven): 0.13.1org.apache.hive:hive-exec (Maven): 0.13.1+1 more product
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.hive:hive (Maven) | before 0.13.1 | 0.13.1 | Patch available | GHSA-w4x9-4f5x-8jj8 |
| — | org.apache.hive:hive-exec (Maven) | before 0.13.1 | 0.13.1 | Patch available | GHSA-w4x9-4f5x-8jj8 |
| — | org.apache.hive:hive-service (Maven) | before 0.13.1 | 0.13.1 | Patch available | GHSA-w4x9-4f5x-8jj8 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.hive:hive (Maven) Vendor— Affected before 0.13.1 Fixed in 0.13.1 Patch available GHSA-w4x9-4f5x-8jj8
- org.apache.hive:hive-exec (Maven) Vendor— Affected before 0.13.1 Fixed in 0.13.1 Patch available GHSA-w4x9-4f5x-8jj8
- org.apache.hive:hive-service (Maven) Vendor— Affected before 0.13.1 Fixed in 0.13.1 Patch available GHSA-w4x9-4f5x-8jj8
Remediation
- Fix · GHSA-w4x9-4f5x-8jj8 org.apache.hive:hive (Maven) Fixed in 0.13.1 Advisory →
- Fix · GHSA-w4x9-4f5x-8jj8 org.apache.hive:hive-exec (Maven) Fixed in 0.13.1 Advisory →
- Fix · GHSA-w4x9-4f5x-8jj8 org.apache.hive:hive-service (Maven) Fixed in 0.13.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-0228
- 2026-10-03 Alias added: GHSA-w4x9-4f5x-8jj8
References
Advisory 2
Other 3
More Apache Hive vulnerabilities
- TI-2018-15196 Jodd before 5.0.4 performs Deserialization of Untrusted JSON Data when setClassMetadataName is set. CVSS 3.1CRITICAL 9.8
- TI-2026-40376 Apache Hive: SSRF vulnerability in Hive Avro Serde due to Insufficient input validation on avro.schema.url CVSS 3.1CRITICAL 9.1
- TI-2018-01187 SQL injection in Apache Hive CVSS 3.0CRITICAL 9.1
- TI-2026-36749 Apache Hive: SQL Injection vulnerability in HiveMetaStore partition-name direct-SQL paths CVSS 3.1CRITICAL 9.8
- TI-2015-06259 The authorization framework in Apache Hive 1.0.0, 1.0.1, 1.1.0, 1.1.1, 1.2.0 and 1.2.1… CVSS 3.0HIGH 8.3
- TI-2020-10925 Uncontrolled resource consumption in Apache Thrift CVSS 3.1HIGH 7.5
Sources
- CVE-2014-0228 · CVE Program
- CVE-2014-0228 · NVD
- FIRST EPSS
- GHSA-w4x9-4f5x-8jj8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences