Apache Hadoop 0.23.x before 0.23.11 and 2.x before 2.4.1, as used in Cloudera CDH 5.0.x…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
Apache Hadoop 0.23.x before 0.23.11 and 2.x before 2.4.1, as used in Cloudera CDH 5.0.x before 5.0.2, do not check authorization for the (1) refreshNamenodes, (2) deleteBlockPool, and (3) shutdownDatanode HDFS admin commands, which allows remote authenticated users to cause a denial of service (DataNodes shutdown) or perform unnecessary operations by issuing a command.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.hadoop:hadoop-common (Maven) | 0.23.0 to before 0.23.11 | 0.23.11 | Patch available | GHSA-9r7g-325h-mxrm |
| — | org.apache.hadoop:hadoop-common (Maven) | 2.0.0 to before 2.4.1 | 2.4.1 | Patch available | GHSA-9r7g-325h-mxrm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.hadoop:hadoop-common (Maven) Vendor— Affected 0.23.0 to before 0.23.11 Fixed in 0.23.11 Patch available GHSA-9r7g-325h-mxrm
- org.apache.hadoop:hadoop-common (Maven) Vendor— Affected 2.0.0 to before 2.4.1 Fixed in 2.4.1 Patch available GHSA-9r7g-325h-mxrm
CPE configurations NVD · 25
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cloudera:cdh:5.0.0:*:*:*:*:*:*:* | 5.0.0 | Vulnerable | Cloudera |
| cpe:2.3:a:cloudera:cdh:5.0.0:beta:*:*:*:*:*:* | 5.0.0 beta | Vulnerable | Cloudera |
| cpe:2.3:a:cloudera:cdh:5.0.0:beta2:*:*:*:*:*:* | 5.0.0 beta2 | Vulnerable | Cloudera |
| cpe:2.3:a:apache:hadoop:0.23.0:*:*:*:*:*:*:* | 0.23.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:0.23.1:*:*:*:*:*:*:* | 0.23.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:0.23.3:*:*:*:*:*:*:* | 0.23.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:0.23.4:*:*:*:*:*:*:* | 0.23.4 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:0.23.5:*:*:*:*:*:*:* | 0.23.5 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:0.23.6:*:*:*:*:*:*:* | 0.23.6 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:0.23.7:*:*:*:*:*:*:* | 0.23.7 | Vulnerable | Apache |
- cpe:2.3:a:cloudera:cdh:5.0.0:*:*:*:*:*:*:* Versions 5.0.0 Vulnerable ·Cloudera
- cpe:2.3:a:cloudera:cdh:5.0.0:beta:*:*:*:*:*:* Versions 5.0.0 beta Vulnerable ·Cloudera
- cpe:2.3:a:cloudera:cdh:5.0.0:beta2:*:*:*:*:*:* Versions 5.0.0 beta2 Vulnerable ·Cloudera
- cpe:2.3:a:apache:hadoop:0.23.0:*:*:*:*:*:*:* Versions 0.23.0 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:0.23.1:*:*:*:*:*:*:* Versions 0.23.1 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:0.23.3:*:*:*:*:*:*:* Versions 0.23.3 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:0.23.4:*:*:*:*:*:*:* Versions 0.23.4 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:0.23.5:*:*:*:*:*:*:* Versions 0.23.5 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:0.23.6:*:*:*:*:*:*:* Versions 0.23.6 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:0.23.7:*:*:*:*:*:*:* Versions 0.23.7 Vulnerable ·Apache
Show 15 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:hadoop:0.23.8:*:*:*:*:*:*:* | 0.23.8 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:0.23.9:*:*:*:*:*:*:* | 0.23.9 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:0.23.10:*:*:*:*:*:*:* | 0.23.10 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.0:alpha:*:*:*:*:*:* | 2.0.0 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.1:alpha:*:*:*:*:*:* | 2.0.1 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.2:alpha:*:*:*:*:*:* | 2.0.2 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.3:alpha:*:*:*:*:*:* | 2.0.3 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.4:alpha:*:*:*:*:*:* | 2.0.4 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.5:alpha:*:*:*:*:*:* | 2.0.5 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.0.6:alpha:*:*:*:*:*:* | 2.0.6 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.1.0:beta:*:*:*:*:*:* | 2.1.0 beta | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.1.1:beta:*:*:*:*:*:* | 2.1.1 beta | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.2.0:*:*:*:*:*:*:* | 2.2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.3.0:*:*:*:*:*:*:* | 2.3.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:hadoop:2.4.0:*:*:*:*:*:*:* | 2.4.0 | Vulnerable | Apache |
- cpe:2.3:a:apache:hadoop:0.23.8:*:*:*:*:*:*:* Versions 0.23.8 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:0.23.9:*:*:*:*:*:*:* Versions 0.23.9 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:0.23.10:*:*:*:*:*:*:* Versions 0.23.10 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.0:alpha:*:*:*:*:*:* Versions 2.0.0 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.1:alpha:*:*:*:*:*:* Versions 2.0.1 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.2:alpha:*:*:*:*:*:* Versions 2.0.2 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.3:alpha:*:*:*:*:*:* Versions 2.0.3 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.4:alpha:*:*:*:*:*:* Versions 2.0.4 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.5:alpha:*:*:*:*:*:* Versions 2.0.5 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.0.6:alpha:*:*:*:*:*:* Versions 2.0.6 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.1.0:beta:*:*:*:*:*:* Versions 2.1.0 beta Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.1.1:beta:*:*:*:*:*:* Versions 2.1.1 beta Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.3.0:*:*:*:*:*:*:* Versions 2.3.0 Vulnerable ·Apache
- cpe:2.3:a:apache:hadoop:2.4.0:*:*:*:*:*:*:* Versions 2.4.0 Vulnerable ·Apache
Remediation
- Fix · GHSA-9r7g-325h-mxrm org.apache.hadoop:hadoop-common (Maven) Fixed in 0.23.11 Advisory →
- Fix · GHSA-9r7g-325h-mxrm org.apache.hadoop:hadoop-common (Maven) Fixed in 2.4.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-0229
- 2026-10-03 Alias added: GHSA-9r7g-325h-mxrm
References
Sources
- CVE-2014-0229 · CVE Program
- CVE-2014-0229 · NVD
- FIRST EPSS
- GHSA-9r7g-325h-mxrm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences