sed command injection
Priority MEDIUM 46CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA. Impact type from CWE-78.
Summary
The set_version script as shipped with obs-service-set_version is a source validator for the Open Build Service (OBS). In versions prior to 0.5.3-1.1 this script did not properly sanitize the input provided by the user, allowing for code execution on the executing server.
Why it matters now
EPSS 0.01869 79th percentileScored 2026-11-07
Fix Fixed obs-service-set_version (openSUSE): 0.5.3-1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA obs-service-set_version (openSUSE) Fixed in 0.5.3-1.1
Timeline
- 2026-10-02 Threatist record created from CVE-2014-0593
- 2026-10-03 Alias added: GHSA-h8fh-v5gw-ch7g
References
More openSUSE Open Build Service vulnerabilities
- TI-2011-03685 open build service allows anyone to upload rpms CVSS 3.0CRITICAL 9.8
- TI-2022-06311 Multiple XXE vulnerabilities in OBS CVSS 3.1HIGH 8.8
- TI-2011-02808 openbuildservice webui code injection CVSS 3.0HIGH 8.8
- TI-2021-14898 login-proxy sends password to attacker-provided domain CVSS 3.1HIGH 8.8
- TI-2014-00570 CSRF protection incorrectly disabled CVSS 3.0HIGH 8.8
- TI-2013-03229 No write permission check in change_role command CVSS 3.0HIGH 8.8
Sources
- CVE-2014-0593 · CVE Program
- CVE-2014-0593 · NVD
- FIRST EPSS
- GHSA-h8fh-v5gw-ch7g · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences