The WSDL/WADL import functionality in SoapUI before 4.6.4 allows remote attackers to…
Priority MEDIUM 50CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Complete · Complete · Complete
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
The WSDL/WADL import functionality in SoapUI before 4.6.4 allows remote attackers to execute arbitrary Java code via a crafted request parameter in a WSDL file.
Why it matters now
EPSS 0.07673 94th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD and the CNA
Fix Fixed com.smartbear.soapui:soapui (Maven): 4.6.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | com.smartbear.soapui:soapui (Maven) | before 4.6.4 | 4.6.4 | Patch available | GHSA-c2fp-mpmm-cqxv |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- com.smartbear.soapui:soapui (Maven) Vendor— Affected before 4.6.4 Fixed in 4.6.4 Patch available GHSA-c2fp-mpmm-cqxv
CPE configurations NVD · 17
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:eviware:soapui:2.5.1:*:*:*:*:*:*:* | 2.5.1 | Vulnerable | Eviware |
| cpe:2.3:a:eviware:soapui:3.0.1:*:*:*:*:*:*:* | 3.0.1 | Vulnerable | Eviware |
| cpe:2.3:a:eviware:soapui:3.5:*:*:*:*:*:*:* | 3.5 | Vulnerable | Eviware |
| cpe:2.3:a:eviware:soapui:3.5.1:*:*:*:*:*:*:* | 3.5.1 | Vulnerable | Eviware |
| cpe:2.3:a:eviware:soapui:3.6:*:*:*:*:*:*:* | 3.6 | Vulnerable | Eviware |
| cpe:2.3:a:eviware:soapui:3.6.1:*:*:*:*:*:*:* | 3.6.1 | Vulnerable | Eviware |
| cpe:2.3:a:smartbear:soapui:*:*:*:*:*:*:*:* | up to 4.6.3 | Vulnerable | SMARTBEAR |
| cpe:2.3:a:smartbear:soapui:4.0:*:*:*:*:*:*:* | 4.0 | Vulnerable | SMARTBEAR |
| cpe:2.3:a:smartbear:soapui:4.0:beta1:*:*:*:*:*:* | 4.0 beta1 | Vulnerable | SMARTBEAR |
| cpe:2.3:a:smartbear:soapui:4.0:beta2:*:*:*:*:*:* | 4.0 beta2 | Vulnerable | SMARTBEAR |
- cpe:2.3:a:eviware:soapui:2.5.1:*:*:*:*:*:*:* Versions 2.5.1 Vulnerable ·Eviware
- cpe:2.3:a:eviware:soapui:3.0.1:*:*:*:*:*:*:* Versions 3.0.1 Vulnerable ·Eviware
- cpe:2.3:a:eviware:soapui:3.5:*:*:*:*:*:*:* Versions 3.5 Vulnerable ·Eviware
- cpe:2.3:a:eviware:soapui:3.5.1:*:*:*:*:*:*:* Versions 3.5.1 Vulnerable ·Eviware
- cpe:2.3:a:eviware:soapui:3.6:*:*:*:*:*:*:* Versions 3.6 Vulnerable ·Eviware
- cpe:2.3:a:eviware:soapui:3.6.1:*:*:*:*:*:*:* Versions 3.6.1 Vulnerable ·Eviware
- cpe:2.3:a:smartbear:soapui:*:*:*:*:*:*:*:* Versions up to 4.6.3 Vulnerable ·SMARTBEAR
- cpe:2.3:a:smartbear:soapui:4.0:*:*:*:*:*:*:* Versions 4.0 Vulnerable ·SMARTBEAR
- cpe:2.3:a:smartbear:soapui:4.0:beta1:*:*:*:*:*:* Versions 4.0 beta1 Vulnerable ·SMARTBEAR
- cpe:2.3:a:smartbear:soapui:4.0:beta2:*:*:*:*:*:* Versions 4.0 beta2 Vulnerable ·SMARTBEAR
Show 7 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:smartbear:soapui:4.0.1:*:*:*:*:*:*:* | 4.0.1 | Vulnerable | SMARTBEAR |
| cpe:2.3:a:smartbear:soapui:4.5:*:*:*:*:*:*:* | 4.5 | Vulnerable | SMARTBEAR |
| cpe:2.3:a:smartbear:soapui:4.5.1:*:*:*:*:*:*:* | 4.5.1 | Vulnerable | SMARTBEAR |
| cpe:2.3:a:smartbear:soapui:4.5.2:*:*:*:*:*:*:* | 4.5.2 | Vulnerable | SMARTBEAR |
| cpe:2.3:a:smartbear:soapui:4.6.0:*:*:*:*:*:*:* | 4.6.0 | Vulnerable | SMARTBEAR |
| cpe:2.3:a:smartbear:soapui:4.6.1:*:*:*:*:*:*:* | 4.6.1 | Vulnerable | SMARTBEAR |
| cpe:2.3:a:smartbear:soapui:4.6.2:*:*:*:*:*:*:* | 4.6.2 | Vulnerable | SMARTBEAR |
- cpe:2.3:a:smartbear:soapui:4.0.1:*:*:*:*:*:*:* Versions 4.0.1 Vulnerable ·SMARTBEAR
- cpe:2.3:a:smartbear:soapui:4.5:*:*:*:*:*:*:* Versions 4.5 Vulnerable ·SMARTBEAR
- cpe:2.3:a:smartbear:soapui:4.5.1:*:*:*:*:*:*:* Versions 4.5.1 Vulnerable ·SMARTBEAR
- cpe:2.3:a:smartbear:soapui:4.5.2:*:*:*:*:*:*:* Versions 4.5.2 Vulnerable ·SMARTBEAR
- cpe:2.3:a:smartbear:soapui:4.6.0:*:*:*:*:*:*:* Versions 4.6.0 Vulnerable ·SMARTBEAR
- cpe:2.3:a:smartbear:soapui:4.6.1:*:*:*:*:*:*:* Versions 4.6.1 Vulnerable ·SMARTBEAR
- cpe:2.3:a:smartbear:soapui:4.6.2:*:*:*:*:*:*:* Versions 4.6.2 Vulnerable ·SMARTBEAR
Remediation
- Fix · GHSA-c2fp-mpmm-cqxv com.smartbear.soapui:soapui (Maven) Fixed in 4.6.4 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 2 products
- Red Hat JBoss SOA Platform 4
- Red Hat JBoss SOA Platform 5
Timeline
- 2026-10-02 Threatist record created from CVE-2014-1202
- 2026-10-03 Alias added: GHSA-c2fp-mpmm-cqxv
References
Other 5
- http://www.youtube.com/watch?v=3lCLE64rsc0
- http://baraktawily.blogspot.com/2014/01/soapui-code-execution-vulnerability-cve.html
- https://github.com/SmartBear/soapui/blob/master/RELEASENOTES.txt
- https://github.com/SmartBear/soapui/commit/6373165649ad74257493c69dbc0569caa7e6b4a6
- https://github.com/SmartBear/soapui
Sources
- CVE-2014-1202 · CVE Program
- CVE-2014-1202 · NVD
- FIRST EPSS
- GHSA-c2fp-mpmm-cqxv · GitHub Advisory Database · CC BY 4.0
- CVE-2014-1202 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences