MAAS API vulnerable to CSRF attack
Priority MEDIUM 43CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
A vulnerability in the REST API of Ubuntu MAAS allows an attacker to cause a logged-in user to execute commands via cross-site scripting. This issue affects MAAS versions prior to 1.9.2.
Why it matters now
EPSS 0.01088 65th percentileScored 2026-11-07
Fix Fixed MAAS (Ubuntu): 1.9.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA MAAS (Ubuntu) Fixed in 1.9.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Ubuntu MAAS 1.9.2
4 records Highest priority Priority MEDIUM 3 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2015-01199 Probe-and-enlist for SeaMicro chassis writes password to the logPriority MEDIUM 44
- TI-2014-01104 get_file_by_name does not check ownerPriority MEDIUM 40
- TI-2014-01106 uuid.uuid1() is not suitable as an unguessable identifier/tokenPriority LOW 26
Timeline
- 2026-10-02 Threatist record created from CVE-2014-1427
- 2026-10-03 Alias added: GHSA-r5fr-m3x2-j65q
References
More Ubuntu vulnerabilities
- TI-2021-02452 Incorrect authorization in Ubuntu linux kernel KEVCVSS 3.1HIGH 8.8
- TI-2007-05153 Stack-based buffer overflow in the cons_options function in options.c in dhcpd in OpenBSD… CVSS 2.0HIGH 7.2
- TI-2004-01032 Multiple vulnerabilities in the IGMP functionality for Linux kernel 2.4.22 to 2.4.28, and… CVSS 2.0HIGH 10.0
- TI-2004-00896 Multiple buffer overflows in libXML 2.6.12 and 2.6.13 (libxml2), and possibly other… CVSS 2.0HIGH 10.0
- TI-2004-00800 Buffer overflow in the QFILEPATHINFO request handler in Samba 3.0.x through 3.0.7 may… CVSS 2.0HIGH 10.0
- TI-2004-00962 Buffer overflow in the exif_read_data function in PHP before 4.3.10 and PHP 5.x up to… CVSS 2.0HIGH 10.0
Sources
- CVE-2014-1427 · CVE Program
- CVE-2014-1427 · NVD
- FIRST EPSS
- GHSA-r5fr-m3x2-j65q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences