Requests (aka python-requests) before 2.3.0 allows remote servers to obtain a netrc…
Priority LOW 27CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Partial Red Hat: 2 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.
Summary
Requests (aka python-requests) before 2.3.0 allows remote servers to obtain a netrc password by reading the Authorization header in a redirected request.
Why it matters now
EPSS 0.022 82nd percentileScored 2026-11-07
Fix Partial requests (PyPI): 2.3.0Red Hat: 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | requests (PyPI) | before 2.3.0 | 2.3.0 | Patch available | GHSA-cfj3-7x9c-4p3h |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- requests (PyPI) Vendor— Affected before 2.3.0 Fixed in 2.3.0 Patch available GHSA-cfj3-7x9c-4p3h
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:a:python:requests:*:*:*:*:*:*:*:* | up to 2.2.1 | Vulnerable | python-pillow |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:mageia:mageia:4.0:*:*:*:*:*:*:* | 4.0 | Vulnerable | Mageia |
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:a:python:requests:*:*:*:*:*:*:*:* Versions up to 2.2.1 Vulnerable ·python-pillow
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:mageia:mageia:4.0:*:*:*:*:*:*:* Versions 4.0 Vulnerable ·Mageia
Remediation
- Fix · GHSA-cfj3-7x9c-4p3h requests (PyPI) Fixed in 2.3.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenStack Platform 3 | Affected | No fix planned: Will not fix |
| Red Hat OpenStack Platform 4 | Affected | No fix yet |
Not affected: 1 product
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2014-1829
- 2026-10-03 Alias added: GHSA-cfj3-7x9c-4p3h
References
Advisory 6
Other 5
- https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=733108
- https://github.com/psf/requests/issues/1885
- https://github.com/psf/requests
- https://github.com/pypa/advisory-database/tree/main/vulns/requests/PYSEC-2014-13.yaml
- https://web.archive.org/web/20150523055216/http://www.mandriva.com/en/support/security/advisories/advisory/MDVSA-2015:133/?name=MDVSA-2015:133
Sources
- CVE-2014-1829 · CVE Program
- CVE-2014-1829 · NVD
- FIRST EPSS
- GHSA-cfj3-7x9c-4p3h · GitHub Advisory Database · CC BY 4.0
- CVE-2014-1829 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences