Erlang Solutions MongooseIM through 1.3.1 rev.
Priority LOW 38CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass, Denial of service
- Confidentiality · integrity · availability
- None · None · Complete
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264 and CWE-770.
Summary
Erlang Solutions MongooseIM through 1.3.1 rev. 2 does not properly restrict the processing of compressed XML elements, which allows remote attackers to cause a denial of service (resource consumption) via a crafted XMPP stream, aka an "xmppbomb" attack.
Why it matters now
EPSS 0.02006 80th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed MongooseIM (Hex): 1.3.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | MongooseIM (Hex) | before 1.3.2 | 1.3.2 | Patch available | GHSA-5v5w-44w6-q5hv |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- MongooseIM (Hex) Vendor— Affected before 1.3.2 Fixed in 1.3.2 Patch available GHSA-5v5w-44w6-q5hv
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:erlang-solutions:mongooseim:*:rev2:*:*:*:*:*:* | up to 1.3.1 | Vulnerable | Erlang-solutions |
| cpe:2.3:a:erlang-solutions:mongooseim:1.2.1:*:*:*:*:*:*:* | 1.2.1 | Vulnerable | Erlang-solutions |
| cpe:2.3:a:erlang-solutions:mongooseim:1.2.2:*:*:*:*:*:*:* | 1.2.2 | Vulnerable | Erlang-solutions |
| cpe:2.3:a:erlang-solutions:mongooseim:1.3.0:*:*:*:*:*:*:* | 1.3.0 | Vulnerable | Erlang-solutions |
| cpe:2.3:a:erlang-solutions:mongooseim:1.3.1:-:*:*:*:*:*:* | 1.3.1 | Vulnerable | Erlang-solutions |
- cpe:2.3:a:erlang-solutions:mongooseim:*:rev2:*:*:*:*:*:* Versions up to 1.3.1 Vulnerable ·Erlang-solutions
- cpe:2.3:a:erlang-solutions:mongooseim:1.2.1:*:*:*:*:*:*:* Versions 1.2.1 Vulnerable ·Erlang-solutions
- cpe:2.3:a:erlang-solutions:mongooseim:1.2.2:*:*:*:*:*:*:* Versions 1.2.2 Vulnerable ·Erlang-solutions
- cpe:2.3:a:erlang-solutions:mongooseim:1.3.0:*:*:*:*:*:*:* Versions 1.3.0 Vulnerable ·Erlang-solutions
- cpe:2.3:a:erlang-solutions:mongooseim:1.3.1:-:*:*:*:*:*:* Versions 1.3.1 Vulnerable ·Erlang-solutions
Remediation
- Fix · GHSA-5v5w-44w6-q5hv MongooseIM (Hex) Fixed in 1.3.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-2829
- 2026-10-03 Alias added: GHSA-5v5w-44w6-q5hv
References
Sources
- CVE-2014-2829 · CVE Program
- CVE-2014-2829 · NVD
- FIRST EPSS
- GHSA-5v5w-44w6-q5hv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences