The getObjectByToken function in Newsletter.php in the Pimcore_Tool_Newsletter module in…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
The getObjectByToken function in Newsletter.php in the Pimcore_Tool_Newsletter module in pimcore 1.4.9 through 2.0.0 does not properly handle an object obtained by unserializing Lucene search data, which allows remote attackers to conduct PHP object injection attacks and execute arbitrary code via vectors involving a Zend_Pdf_ElementFactory_Proxy object and a pathname with a trailing \0 character.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | pimcore/pimcore (Packagist) | 1.4.9 to before 2.2.0 | 2.2.0 | Patch available | GHSA-g7pj-3v97-3vxp |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- pimcore/pimcore (Packagist) Vendor— Affected 1.4.9 to before 2.2.0 Fixed in 2.2.0 Patch available GHSA-g7pj-3v97-3vxp
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pimcore:pimcore:1.4.9:*:*:*:*:*:*:* | 1.4.9 | Vulnerable | pimcore |
| cpe:2.3:a:pimcore:pimcore:1.5.0:*:*:*:*:*:*:* | 1.5.0 | Vulnerable | pimcore |
| cpe:2.3:a:pimcore:pimcore:2.1.0:*:*:*:*:*:*:* | 2.1.0 | Vulnerable | pimcore |
| cpe:2.3:a:pimcore:pimcore:2.2.0:*:*:*:*:*:*:* | 2.2.0 | Vulnerable | pimcore |
- cpe:2.3:a:pimcore:pimcore:1.4.9:*:*:*:*:*:*:* Versions 1.4.9 Vulnerable ·pimcore
- cpe:2.3:a:pimcore:pimcore:1.5.0:*:*:*:*:*:*:* Versions 1.5.0 Vulnerable ·pimcore
- cpe:2.3:a:pimcore:pimcore:2.1.0:*:*:*:*:*:*:* Versions 2.1.0 Vulnerable ·pimcore
- cpe:2.3:a:pimcore:pimcore:2.2.0:*:*:*:*:*:*:* Versions 2.2.0 Vulnerable ·pimcore
Remediation
- Fix · GHSA-g7pj-3v97-3vxp pimcore/pimcore (Packagist) Fixed in 2.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-2921
- 2026-10-03 Alias added: GHSA-g7pj-3v97-3vxp
References
More Pimcore vulnerabilities
- TI-2026-18925 Pimcore has a Blind SQL Injection in Admin Search Find API due to an incomplete fix for CVE-2023-30848 CVSS 3.1HIGH 8.8
- TI-2026-18926 Pimcore ENV Variables and Cookie Informations are exposed in http_error_log CVSS 3.1HIGH 8.6
- TI-2023-01489 SQL Injection in pimcore/pimcore CVSS 3.1HIGH 8.8
- TI-2019-08091 An issue was discovered in Pimcore before 5.7.1. CVSS 3.0HIGH 8.8
- TI-2023-25778 SQL Injection in Admin Grid Filter API in Pimcore CVSS 3.1HIGH 8.8
- TI-2023-10682 An improper SameSite Attribute vulnerability in pimCore v10.5.15 allows attackers to execute arbitrary code. CVSS 3.1HIGH 8.8
Sources
- CVE-2014-2921 · CVE Program
- CVE-2014-2921 · NVD
- FIRST EPSS
- GHSA-g7pj-3v97-3vxp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences