Python Image Library (PIL) 1.1.7 and earlier and Pillow 2.3 might allow remote attackers…
Priority MEDIUM 55CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Complete · Complete · Complete
- Fix status
- Partial Red Hat: 3 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-78.
Summary
Python Image Library (PIL) 1.1.7 and earlier and Pillow 2.3 might allow remote attackers to execute arbitrary commands via shell metacharacters in unspecified vectors related to CVE-2014-1932, possibly JpegImagePlugin.py.
Why it matters now
EPSS 0.10356 95th percentileScored 2026-11-07
Fix Partial pillow (PyPI): 2.5.0Red Hat: 3 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | pillow (PyPI) | before 2.5.0 | 2.5.0 | Patch available | GHSA-8m9x-pxwq-j236 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- pillow (PyPI) Vendor— Affected before 2.5.0 Fixed in 2.5.0 Patch available GHSA-8m9x-pxwq-j236
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:python:pillow:2.3.0:*:*:*:*:*:*:* | 2.3.0 | Vulnerable | python-pillow |
| cpe:2.3:a:pythonware:python_imaging_library:*:*:*:*:*:*:*:* | up to 1.1.7 | Vulnerable | Pythonware |
- cpe:2.3:a:python:pillow:2.3.0:*:*:*:*:*:*:* Versions 2.3.0 Vulnerable ·python-pillow
- cpe:2.3:a:pythonware:python_imaging_library:*:*:*:*:*:*:*:* Versions up to 1.1.7 Vulnerable ·Pythonware
Remediation
- Fix · GHSA-8m9x-pxwq-j236 pillow (PyPI) Fixed in 2.5.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 5 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2014-3007
- 2026-10-03 Alias added: GHSA-8m9x-pxwq-j236
References
Sources
- CVE-2014-3007 · CVE Program
- CVE-2014-3007 · NVD
- FIRST EPSS
- GHSA-8m9x-pxwq-j236 · GitHub Advisory Database · CC BY 4.0
- CVE-2014-3007 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences