Untrusted search path vulnerability in Puppet Enterprise 2.8 before 2.8.7, Puppet before…
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- Complete · Complete · Complete
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Untrusted search path vulnerability in Puppet Enterprise 2.8 before 2.8.7, Puppet before 2.7.26 and 3.x before 3.6.2, Facter 1.6.x and 2.x before 2.0.2, Hiera before 1.3.4, and Mcollective before 2.5.2, when running with Ruby 1.9.1 or earlier, allows local users to gain privileges via a Trojan horse file in the current working directory, as demonstrated using (1) rubygems/defaults/operating_system.rb, (2) Win32API.rb, (3) Win32API.so, (4) safe_yaml.rb, (5) safe_yaml/deep.rb, or (6) safe_yaml/deep.so; or (7) operatingsystem.rb, (8) operatingsystem.so, (9) osfamily.rb, or (10) osfamily.so in puppet/confine.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | facter (RubyGems) | before 1.7.6 | 1.7.6 | Patch available | GHSA-92v7-pq4h-58j5 |
| — | facter (RubyGems) | 2.0.0 to before 2.0.2 | 2.0.2 | Patch available | GHSA-92v7-pq4h-58j5 |
| — | hiera (RubyGems) | before 1.3.4 | 1.3.4 | Patch available | GHSA-92v7-pq4h-58j5 |
| — | puppet (RubyGems) | before 2.7.26 | 2.7.26 | Patch available | GHSA-92v7-pq4h-58j5 |
| — | puppet (RubyGems) | 3.0.0 to before 3.6.2 | 3.6.2 | Patch available | GHSA-92v7-pq4h-58j5 |
| — | mcollective-client (RubyGems) | before 2.5.2 | 2.5.2 | Patch available | GHSA-92v7-pq4h-58j5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- facter (RubyGems) Vendor— Affected before 1.7.6 Fixed in 1.7.6 Patch available GHSA-92v7-pq4h-58j5
- facter (RubyGems) Vendor— Affected 2.0.0 to before 2.0.2 Fixed in 2.0.2 Patch available GHSA-92v7-pq4h-58j5
- hiera (RubyGems) Vendor— Affected before 1.3.4 Fixed in 1.3.4 Patch available GHSA-92v7-pq4h-58j5
- puppet (RubyGems) Vendor— Affected before 2.7.26 Fixed in 2.7.26 Patch available GHSA-92v7-pq4h-58j5
- puppet (RubyGems) Vendor— Affected 3.0.0 to before 3.6.2 Fixed in 3.6.2 Patch available GHSA-92v7-pq4h-58j5
- mcollective-client (RubyGems) Vendor— Affected before 2.5.2 Fixed in 2.5.2 Patch available GHSA-92v7-pq4h-58j5
CPE configurations NVD · 14
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:puppet:facter:2.0.0:rc1:*:*:*:*:*:* | 2.0.0 rc1 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:facter:2.0.0:rc2:*:*:*:*:*:* | 2.0.0 rc2 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:facter:2.0.0:rc3:*:*:*:*:*:* | 2.0.0 rc3 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:facter:2.0.0:rc4:*:*:*:*:*:* | 2.0.0 rc4 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:facter:2.0.1:-:*:*:*:*:*:* | 2.0.1 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:facter:2.0.1:rc1:*:*:*:*:*:* | 2.0.1 rc1 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:facter:2.0.1:rc2:*:*:*:*:*:* | 2.0.1 rc2 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:facter:2.0.1:rc3:*:*:*:*:*:* | 2.0.1 rc3 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:facter:2.0.1:rc4:*:*:*:*:*:* | 2.0.1 rc4 | Vulnerable | Puppet |
| cpe:2.3:a:puppetlabs:facter:*:*:*:*:*:*:*:* | 1.6.0 – 1.6.18 | Vulnerable | Puppetlabs |
- cpe:2.3:a:puppet:facter:2.0.0:rc1:*:*:*:*:*:* Versions 2.0.0 rc1 Vulnerable ·Puppet
- cpe:2.3:a:puppet:facter:2.0.0:rc2:*:*:*:*:*:* Versions 2.0.0 rc2 Vulnerable ·Puppet
- cpe:2.3:a:puppet:facter:2.0.0:rc3:*:*:*:*:*:* Versions 2.0.0 rc3 Vulnerable ·Puppet
- cpe:2.3:a:puppet:facter:2.0.0:rc4:*:*:*:*:*:* Versions 2.0.0 rc4 Vulnerable ·Puppet
- cpe:2.3:a:puppet:facter:2.0.1:-:*:*:*:*:*:* Versions 2.0.1 Vulnerable ·Puppet
- cpe:2.3:a:puppet:facter:2.0.1:rc1:*:*:*:*:*:* Versions 2.0.1 rc1 Vulnerable ·Puppet
- cpe:2.3:a:puppet:facter:2.0.1:rc2:*:*:*:*:*:* Versions 2.0.1 rc2 Vulnerable ·Puppet
- cpe:2.3:a:puppet:facter:2.0.1:rc3:*:*:*:*:*:* Versions 2.0.1 rc3 Vulnerable ·Puppet
- cpe:2.3:a:puppet:facter:2.0.1:rc4:*:*:*:*:*:* Versions 2.0.1 rc4 Vulnerable ·Puppet
- cpe:2.3:a:puppetlabs:facter:*:*:*:*:*:*:*:* Versions 1.6.0 – 1.6.18 Vulnerable ·Puppetlabs
Show 4 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:puppet:marionette_collective:*:*:*:*:*:*:*:* | before 2.5.2 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:hiera:*:*:*:*:*:*:*:* | before 1.3.4 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet:*:*:*:*:*:*:*:* | before 2.7.26; 3.6.0 to before 3.6.2 | Vulnerable | Puppet |
| cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:* | 2.8.0 to before 2.8.7 | Vulnerable | Puppet |
- cpe:2.3:a:puppet:marionette_collective:*:*:*:*:*:*:*:* Versions before 2.5.2 Vulnerable ·Puppet
- cpe:2.3:a:puppet:hiera:*:*:*:*:*:*:*:* Versions before 1.3.4 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet:*:*:*:*:*:*:*:* Versions before 2.7.26; 3.6.0 to before 3.6.2 Vulnerable ·Puppet
- cpe:2.3:a:puppet:puppet_enterprise:*:*:*:*:*:*:*:* Versions 2.8.0 to before 2.8.7 Vulnerable ·Puppet
Remediation
- Fix · GHSA-92v7-pq4h-58j5 facter (RubyGems) Fixed in 1.7.6 Advisory →
- Fix · GHSA-92v7-pq4h-58j5 facter (RubyGems) Fixed in 2.0.2 Advisory →
- Fix · GHSA-92v7-pq4h-58j5 hiera (RubyGems) Fixed in 1.3.4 Advisory →
- Fix · GHSA-92v7-pq4h-58j5 puppet (RubyGems) Fixed in 2.7.26 Advisory →
- Fix · GHSA-92v7-pq4h-58j5 puppet (RubyGems) Fixed in 3.6.2 Advisory →
- Fix · GHSA-92v7-pq4h-58j5 mcollective-client (RubyGems) Fixed in 2.5.2 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenStack Platform 3 | Affected | No fix planned: Will not fix |
Not affected: 4 products
- Red Hat Enterprise Linux OpenStack Platform 5 (Icehouse)
- Red Hat OpenStack Platform 4
- Red Hat Satellite 6
- Red Hat Subscription Asset Manager
Timeline
- 2026-10-02 Threatist record created from CVE-2014-3248
- 2026-10-03 Alias added: GHSA-92v7-pq4h-58j5
References
Advisory 2
Other 7
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/facter/CVE-2014-3248.yml
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/hiera/CVE-2014-3248.yml
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/mcollective-client/CVE-2014-3248.yml
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puppet/CVE-2014-3248.yml
- https://web.archive.org/web/20141129061319/http://www.securityfocus.com/bid/68035
- https://web.archive.org/web/20150204183209/http://rowediness.com/2014/06/13/cve-2014-3248-a-little-problem-with-puppet
- https://web.archive.org/web/20150907182402/http://puppetlabs.com/security/cve/cve-2014-3248
Sources
- CVE-2014-3248 · CVE Program
- CVE-2014-3248 · NVD
- FIRST EPSS
- GHSA-92v7-pq4h-58j5 · GitHub Advisory Database · CC BY 4.0
- CVE-2014-3248 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences