Apache Wicket before 1.5.12, 6.x before 6.17.0, and 7.x before 7.0.0-M3 might allow…
Priority LOW 37CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Apache Wicket before 1.5.12, 6.x before 6.17.0, and 7.x before 7.0.0-M3 might allow remote attackers to obtain sensitive information via vectors involving identifiers for storing page markup for temporary user sessions.
Why it matters now
EPSS 0.02297 83rd percentileScored 2026-11-07
Fix Fixed org.apache.wicket:wicket-core (Maven): 1.5.12, 6.17.0, 7.0.0-M3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.apache.wicket:wicket-core (Maven) | before 1.5.12 | 1.5.12 | Patch available | GHSA-q7wx-mhx4-jr8q |
| — | org.apache.wicket:wicket-core (Maven) | 6.0 to before 6.17.0 | 6.17.0 | Patch available | GHSA-q7wx-mhx4-jr8q |
| — | org.apache.wicket:wicket-core (Maven) | 7.0.0-M1 to before 7.0.0-M3 | 7.0.0-M3 | Patch available | GHSA-q7wx-mhx4-jr8q |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.apache.wicket:wicket-core (Maven) Vendor— Affected before 1.5.12 Fixed in 1.5.12 Patch available GHSA-q7wx-mhx4-jr8q
- org.apache.wicket:wicket-core (Maven) Vendor— Affected 6.0 to before 6.17.0 Fixed in 6.17.0 Patch available GHSA-q7wx-mhx4-jr8q
- org.apache.wicket:wicket-core (Maven) Vendor— Affected 7.0.0-M1 to before 7.0.0-M3 Fixed in 7.0.0-M3 Patch available GHSA-q7wx-mhx4-jr8q
CPE configurations NVD · 26
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:wicket:*:*:*:*:*:*:*:* | 1.5.0 to before 1.5.12 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.0.0:*:*:*:*:*:*:* | 6.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.0.0:beta1:*:*:*:*:*:* | 6.0.0 beta1 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.0.0:beta2:*:*:*:*:*:* | 6.0.0 beta2 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.0.0:beta3:*:*:*:*:*:* | 6.0.0 beta3 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.1.0:*:*:*:*:*:*:* | 6.1.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.1.1:*:*:*:*:*:*:* | 6.1.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.2.0:*:*:*:*:*:*:* | 6.2.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.3.0:*:*:*:*:*:*:* | 6.3.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.4.0:*:*:*:*:*:*:* | 6.4.0 | Vulnerable | Apache |
- cpe:2.3:a:apache:wicket:*:*:*:*:*:*:*:* Versions 1.5.0 to before 1.5.12 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.0.0:*:*:*:*:*:*:* Versions 6.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.0.0:beta1:*:*:*:*:*:* Versions 6.0.0 beta1 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.0.0:beta2:*:*:*:*:*:* Versions 6.0.0 beta2 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.0.0:beta3:*:*:*:*:*:* Versions 6.0.0 beta3 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.1.0:*:*:*:*:*:*:* Versions 6.1.0 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.1.1:*:*:*:*:*:*:* Versions 6.1.1 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.2.0:*:*:*:*:*:*:* Versions 6.2.0 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.3.0:*:*:*:*:*:*:* Versions 6.3.0 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.4.0:*:*:*:*:*:*:* Versions 6.4.0 Vulnerable ·Apache
Show 16 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:wicket:6.5.0:*:*:*:*:*:*:* | 6.5.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.6.0:*:*:*:*:*:*:* | 6.6.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.7.0:*:*:*:*:*:*:* | 6.7.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.8.0:*:*:*:*:*:*:* | 6.8.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.9.0:*:*:*:*:*:*:* | 6.9.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.9.1:*:*:*:*:*:*:* | 6.9.1 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.10.0:*:*:*:*:*:*:* | 6.10.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.11.0:*:*:*:*:*:*:* | 6.11.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.12.0:*:*:*:*:*:*:* | 6.12.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.13.0:*:*:*:*:*:*:* | 6.13.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.14.0:*:*:*:*:*:*:* | 6.14.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.15.0:*:*:*:*:*:*:* | 6.15.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:6.16.0:*:*:*:*:*:*:* | 6.16.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:7.0.0:*:*:*:*:*:*:* | 7.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:7.0.0:milestone1:*:*:*:*:*:* | 7.0.0 milestone1 | Vulnerable | Apache |
| cpe:2.3:a:apache:wicket:7.0.0:milestone2:*:*:*:*:*:* | 7.0.0 milestone2 | Vulnerable | Apache |
- cpe:2.3:a:apache:wicket:6.5.0:*:*:*:*:*:*:* Versions 6.5.0 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.6.0:*:*:*:*:*:*:* Versions 6.6.0 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.7.0:*:*:*:*:*:*:* Versions 6.7.0 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.8.0:*:*:*:*:*:*:* Versions 6.8.0 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.9.0:*:*:*:*:*:*:* Versions 6.9.0 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.9.1:*:*:*:*:*:*:* Versions 6.9.1 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.10.0:*:*:*:*:*:*:* Versions 6.10.0 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.11.0:*:*:*:*:*:*:* Versions 6.11.0 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.12.0:*:*:*:*:*:*:* Versions 6.12.0 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.13.0:*:*:*:*:*:*:* Versions 6.13.0 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.14.0:*:*:*:*:*:*:* Versions 6.14.0 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.15.0:*:*:*:*:*:*:* Versions 6.15.0 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:6.16.0:*:*:*:*:*:*:* Versions 6.16.0 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:7.0.0:*:*:*:*:*:*:* Versions 7.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:7.0.0:milestone1:*:*:*:*:*:* Versions 7.0.0 milestone1 Vulnerable ·Apache
- cpe:2.3:a:apache:wicket:7.0.0:milestone2:*:*:*:*:*:* Versions 7.0.0 milestone2 Vulnerable ·Apache
Remediation
- Fix · GHSA-q7wx-mhx4-jr8q org.apache.wicket:wicket-core (Maven) Fixed in 1.5.12 Advisory →
- Fix · GHSA-q7wx-mhx4-jr8q org.apache.wicket:wicket-core (Maven) Fixed in 6.17.0 Advisory →
- Fix · GHSA-q7wx-mhx4-jr8q org.apache.wicket:wicket-core (Maven) Fixed in 7.0.0-M3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-3526
- 2026-10-03 Alias added: GHSA-q7wx-mhx4-jr8q
References
More Apache Wicket vulnerabilities
- TI-2016-05834 The DiskFileItem class in Apache Wicket 6.x before 6.25.0 and 1.5.x before 1.5.17 allows… CVSS 3.0CRITICAL 9.1
- TI-2026-28853 Apache Wicket: possible session fixation using AuthenticatedWebSession CVSS 3.1CRITICAL 9.1
- TI-2024-24295 Apache Wicket: Remote code execution via XSLT injection CVSS 3.1CRITICAL 9.8
- TI-2026-49926 Apache Wicket: Configured file upload limits are not enforced when the multipart request has already been parsed CVSS 3.1HIGH 7.5
- TI-2021-06275 DNS proxy and possible amplification attack CVSS 3.1HIGH 7.5
- TI-2016-05847 Cross-site request forgery in Apache Wicket CVSS 3.0HIGH 8.8
Sources
- CVE-2014-3526 · CVE Program
- CVE-2014-3526 · NVD
- FIRST EPSS
- GHSA-q7wx-mhx4-jr8q · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences