Improper authentication in Pivotal Spring Security
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
When using the CAS Proxy ticket authentication from Spring Security 3.1 to 3.2.4 a malicious CAS Service could trick another CAS Service into authenticating a proxy ticket that was not associated. This is due to the fact that the proxy ticket authentication uses the information from the HttpServletRequest which is populated based upon untrusted information within the HTTP request. This means if there are access control restrictions on which CAS services can authenticate to one another, those restrictions can be bypassed. If users are not using CAS Proxy tickets and not basing access control decisions based upon the CAS Service, then there is no impact to users.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Pivotal | Spring Security | 3.1 to 3.2.4 | — | No fix listed | CNA |
| — | org.springframework.security:spring-security-core (Maven) | before 3.1.7 | 3.1.7 | Patch available | GHSA-wmv4-5w76-vp9g |
| — | org.springframework.security:spring-security-core (Maven) | 3.2.0 to before 3.2.5 | 3.2.5 | Patch available | GHSA-wmv4-5w76-vp9g |
- Spring Security VendorPivotal Affected 3.1 to 3.2.4 Fixed in — No fix listed CNA
- org.springframework.security:spring-security-core (Maven) Vendor— Affected before 3.1.7 Fixed in 3.1.7 Patch available GHSA-wmv4-5w76-vp9g
- org.springframework.security:spring-security-core (Maven) Vendor— Affected 3.2.0 to before 3.2.5 Fixed in 3.2.5 Patch available GHSA-wmv4-5w76-vp9g
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vmware:spring_security:3.1.0:*:*:*:*:*:*:* | 3.1.0 | Vulnerable | VMware |
| cpe:2.3:a:vmware:spring_security:3.1.1:*:*:*:*:*:*:* | 3.1.1 | Vulnerable | VMware |
| cpe:2.3:a:vmware:spring_security:3.1.2:*:*:*:*:*:*:* | 3.1.2 | Vulnerable | VMware |
| cpe:2.3:a:vmware:spring_security:3.1.3:*:*:*:*:*:*:* | 3.1.3 | Vulnerable | VMware |
| cpe:2.3:a:vmware:spring_security:3.1.4:*:*:*:*:*:*:* | 3.1.4 | Vulnerable | VMware |
| cpe:2.3:a:vmware:spring_security:3.2.0:*:*:*:*:*:*:* | 3.2.0 | Vulnerable | VMware |
| cpe:2.3:a:vmware:spring_security:3.2.1:*:*:*:*:*:*:* | 3.2.1 | Vulnerable | VMware |
| cpe:2.3:a:vmware:spring_security:3.2.2:*:*:*:*:*:*:* | 3.2.2 | Vulnerable | VMware |
| cpe:2.3:a:vmware:spring_security:3.2.3:*:*:*:*:*:*:* | 3.2.3 | Vulnerable | VMware |
| cpe:2.3:a:vmware:spring_security:3.2.4:*:*:*:*:*:*:* | 3.2.4 | Vulnerable | VMware |
- cpe:2.3:a:vmware:spring_security:3.1.0:*:*:*:*:*:*:* Versions 3.1.0 Vulnerable ·VMware
- cpe:2.3:a:vmware:spring_security:3.1.1:*:*:*:*:*:*:* Versions 3.1.1 Vulnerable ·VMware
- cpe:2.3:a:vmware:spring_security:3.1.2:*:*:*:*:*:*:* Versions 3.1.2 Vulnerable ·VMware
- cpe:2.3:a:vmware:spring_security:3.1.3:*:*:*:*:*:*:* Versions 3.1.3 Vulnerable ·VMware
- cpe:2.3:a:vmware:spring_security:3.1.4:*:*:*:*:*:*:* Versions 3.1.4 Vulnerable ·VMware
- cpe:2.3:a:vmware:spring_security:3.2.0:*:*:*:*:*:*:* Versions 3.2.0 Vulnerable ·VMware
- cpe:2.3:a:vmware:spring_security:3.2.1:*:*:*:*:*:*:* Versions 3.2.1 Vulnerable ·VMware
- cpe:2.3:a:vmware:spring_security:3.2.2:*:*:*:*:*:*:* Versions 3.2.2 Vulnerable ·VMware
- cpe:2.3:a:vmware:spring_security:3.2.3:*:*:*:*:*:*:* Versions 3.2.3 Vulnerable ·VMware
- cpe:2.3:a:vmware:spring_security:3.2.4:*:*:*:*:*:*:* Versions 3.2.4 Vulnerable ·VMware
Remediation
- Fix · GHSA-wmv4-5w76-vp9g org.springframework.security:spring-security-core (Maven) Fixed in 3.1.7 Advisory →
- Fix · GHSA-wmv4-5w76-vp9g org.springframework.security:spring-security-core (Maven) Fixed in 3.2.5 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat Enterprise Virtualization 3
Timeline
- 2026-10-02 Threatist record created from CVE-2014-3527
- 2026-10-03 Alias added: GHSA-wmv4-5w76-vp9g
References
More Pivotal vulnerabilities
- TI-2017-05637 Improper input validation in Pivotal Spring Data REST and Spring Boot CVSS 3.0CRITICAL 9.8
- TI-2016-04299 When processing authorization requests using the whitelabel views in Spring Security… CVSS 3.0HIGH 8.8
- TI-2018-01165 Code injection in Pivotal Spring Security OAuth CVSS 3.0CRITICAL 9.8
- TI-2018-11237 DoS Attack via Range Requests CVSS 3.1HIGH 7.5
- TI-2019-02791 Apps Manager unverified SSL certs in Cloud Controller proxy CVSS 3.0CRITICAL 9.8
- TI-2018-11239 On Demand Services SDK Timing Attack Vulnerability CVSS 3.0CRITICAL 9.8
Sources
- CVE-2014-3527 · CVE Program
- CVE-2014-3527 · NVD
- FIRST EPSS
- GHSA-wmv4-5w76-vp9g · GitHub Advisory Database · CC BY 4.0
- CVE-2014-3527 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences