The Jpeg2KImagePlugin plugin in Pillow before 2.5.3 allows remote attackers to cause a…
Priority LOW 27CWE-399Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-399 and the CVSS impact.
Summary
The Jpeg2KImagePlugin plugin in Pillow before 2.5.3 allows remote attackers to cause a denial of service via a crafted image.
Why it matters now
EPSS 0.01993 80th percentileScored 2026-11-07
Fix Fixed pillow (PyPI): 2.5.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | pillow (PyPI) | before 2.5.3 | 2.5.3 | Patch available | GHSA-j6f7-g425-4gmx |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- pillow (PyPI) Vendor— Affected before 2.5.3 Fixed in 2.5.3 Patch available GHSA-j6f7-g425-4gmx
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:* | 13.2 | Vulnerable | openSUSE |
| cpe:2.3:a:python:pillow:*:*:*:*:*:*:*:* | up to 2.5.2 | Vulnerable | python-pillow |
- cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:* Versions 13.2 Vulnerable ·openSUSE
- cpe:2.3:a:python:pillow:*:*:*:*:*:*:*:* Versions up to 2.5.2 Vulnerable ·python-pillow
Remediation
- Fix · GHSA-j6f7-g425-4gmx pillow (PyPI) Fixed in 2.5.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 3 products
- Red Hat Enterprise Linux 5
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2014-3598
- 2026-10-03 Alias added: GHSA-j6f7-g425-4gmx
References
Advisory 3
Sources
- CVE-2014-3598 · CVE Program
- CVE-2014-3598 · NVD
- FIRST EPSS
- GHSA-j6f7-g425-4gmx · GitHub Advisory Database · CC BY 4.0
- CVE-2014-3598 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences