Jenkins before 1.583 and LTS before 1.565.3 does not properly prevent downloading of…
Priority LOW 22CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Partial · None · None
- Fix status
- Partial Red Hat: 2 fixed, 1 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.
Summary
Jenkins before 1.583 and LTS before 1.565.3 does not properly prevent downloading of plugins, which allows remote authenticated users with the Overall/READ permission to obtain sensitive information by reading the plugin code.
Why it matters now
EPSS 0.01361 71st percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 1.583, 1.565.3Red Hat: 1 advisoryRed Hat: 2 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 1.566 to before 1.583 | 1.583 | Patch available | GHSA-5xm3-48v5-6h7v |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 1.565.3 | 1.565.3 | Patch available | GHSA-5xm3-48v5-6h7v |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 1.566 to before 1.583 Fixed in 1.583 Patch available GHSA-5xm3-48v5-6h7v
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 1.565.3 Fixed in 1.565.3 Patch available GHSA-5xm3-48v5-6h7v
Remediation
- Fix · GHSA-5xm3-48v5-6h7v org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.583 Advisory →
- Fix · GHSA-5xm3-48v5-6h7v org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.565.3 Advisory →
Red Hat 1 advisory
- RHSA-2016:0070 Released 2016-01-26 · Red Hat rating ImportantRed Hat OpenShift Enterprise 3.1.1 bug fix and enhancement update
- Red Hat OpenShift Enterprise 3.1 atomic-openshift-3.1.1.6-1.git.0.b57e8bd.el7aos, atomic-openshift-clients-3.1.1.6-1.git.0.b57e8bd.el7aos, atomic-openshift-clients-redistributable-3.1.1.6-1.git.0.b57e8bd.el7aos +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Enterprise 1 | Affected | No fix yet |
| RHOSE Node 2.1 | Fixed | — |
| Red Hat OpenShift Enterprise 3.1 | Fixed | RHSA-2016:0070 |
Timeline
- 2026-10-02 Threatist record created from CVE-2014-3667
- 2026-10-03 Alias added: GHSA-5xm3-48v5-6h7v
References
Advisory 3
Sources
- CVE-2014-3667 · CVE Program
- CVE-2014-3667 · NVD
- FIRST EPSS
- GHSA-5xm3-48v5-6h7v · GitHub Advisory Database · CC BY 4.0
- CVE-2014-3667 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences