Cross-site scripting (XSS) vulnerability in Jenkins before 1.583 and LTS before 1.565.3…
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Partial · None
- Fix status
- Partial Red Hat: 2 fixed, 1 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
Cross-site scripting (XSS) vulnerability in Jenkins before 1.583 and LTS before 1.565.3 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Why it matters now
EPSS 0.02132 82nd percentileScored 2026-11-07
Fix Partial org.jenkins-ci.main:jenkins-core (Maven): 1.583, 1.565.3Red Hat: 1 advisoryRed Hat: 2 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jenkins-ci.main:jenkins-core (Maven) | 1.566 to before 1.583 | 1.583 | Patch available | GHSA-cwh9-f8m6-6r63 |
| — | org.jenkins-ci.main:jenkins-core (Maven) | before 1.565.3 | 1.565.3 | Patch available | GHSA-cwh9-f8m6-6r63 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected 1.566 to before 1.583 Fixed in 1.583 Patch available GHSA-cwh9-f8m6-6r63
- org.jenkins-ci.main:jenkins-core (Maven) Vendor— Affected before 1.565.3 Fixed in 1.565.3 Patch available GHSA-cwh9-f8m6-6r63
Remediation
- Fix · GHSA-cwh9-f8m6-6r63 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.583 Advisory →
- Fix · GHSA-cwh9-f8m6-6r63 org.jenkins-ci.main:jenkins-core (Maven) Fixed in 1.565.3 Advisory →
Red Hat 1 advisory
- RHSA-2016:0070 Released 2016-01-26 · Red Hat rating ImportantRed Hat OpenShift Enterprise 3.1.1 bug fix and enhancement update
- Red Hat OpenShift Enterprise 3.1 atomic-openshift-3.1.1.6-1.git.0.b57e8bd.el7aos, atomic-openshift-clients-3.1.1.6-1.git.0.b57e8bd.el7aos, atomic-openshift-clients-redistributable-3.1.1.6-1.git.0.b57e8bd.el7aos +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Enterprise 1 | Affected | No fix planned: Will not fix |
| RHOSE Node 2.1 | Fixed | — |
| Red Hat OpenShift Enterprise 3.1 | Fixed | RHSA-2016:0070 |
Timeline
- 2026-10-02 Threatist record created from CVE-2014-3681
- 2026-10-03 Alias added: GHSA-cwh9-f8m6-6r63
References
Advisory 4
Sources
- CVE-2014-3681 · CVE Program
- CVE-2014-3681 · NVD
- FIRST EPSS
- GHSA-cwh9-f8m6-6r63 · GitHub Advisory Database · CC BY 4.0
- CVE-2014-3681 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences