The printDirect function in lib/printer.js in the node-printer module 0.0.1 and earlier…
Priority MEDIUM 49CWE-77Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-77.
Summary
The printDirect function in lib/printer.js in the node-printer module 0.0.1 and earlier for Node.js allows remote attackers to execute arbitrary commands via unspecified characters in the lpr command.
Why it matters now
EPSS 0.03759 89th percentileScored 2026-11-07
Fix Fixed printer (npm): 0.0.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | printer (npm) | before 0.0.2 | 0.0.2 | Patch available | GHSA-5c8j-xr24-2665 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- printer (npm) Vendor— Affected before 0.0.2 Fixed in 0.0.2 Patch available GHSA-5c8j-xr24-2665
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:node-printer_project:node-printer:*:*:*:*:*:node.js:*:* | up to 0.0.1 | Vulnerable | Node-printer Project |
- cpe:2.3:a:node-printer_project:node-printer:*:*:*:*:*:node.js:*:* Versions up to 0.0.1 Vulnerable ·Node-printer Project
Remediation
- Fix · GHSA-5c8j-xr24-2665 printer (npm) Fixed in 0.0.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-3741
- 2026-10-03 Alias added: GHSA-5c8j-xr24-2665
References
Advisory 5
- [oss-security] 20140514 Re: CVE request: various NodeJS module vulnerabilities
- [oss-security] 20140513 CVE request: various NodeJS module vulnerabilities
- https://nodesecurity.io/advisories/printer_potential_command_injection
- https://nvd.nist.gov/vuln/detail/CVE-2014-3741
- https://github.com/advisories/GHSA-5c8j-xr24-2665
Sources
- CVE-2014-3741 · CVE Program
- CVE-2014-3741 · NVD
- FIRST EPSS
- GHSA-5c8j-xr24-2665 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences