The hapi server framework 2.0.x and 2.1.x before 2.2.0 for Node.js allows remote…
Priority LOW 27CWE-399Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-399 and the CVSS impact.
Summary
The hapi server framework 2.0.x and 2.1.x before 2.2.0 for Node.js allows remote attackers to cause a denial of service (file descriptor consumption and process crash) via unspecified vectors.
Why it matters now
EPSS 0.02374 83rd percentileScored 2026-11-07
Fix Fixed hapi (npm): 2.2.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | hapi (npm) | 2.0.0 to before 2.2.0 | 2.2.0 | Patch available | GHSA-cqr7-78pj-3g7j |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- hapi (npm) Vendor— Affected 2.0.0 to before 2.2.0 Fixed in 2.2.0 Patch available GHSA-cqr7-78pj-3g7j
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:spumko_project:hapi_server_framework:2.0.0:-:*:*:*:node.js:*:* | 2.0.0 | Vulnerable | Spumko Project |
| cpe:2.3:a:spumko_project:hapi_server_framework:2.0.0:preview:*:*:*:node.js:*:* | 2.0.0 preview | Vulnerable | Spumko Project |
| cpe:2.3:a:spumko_project:hapi_server_framework:2.1.1:*:*:*:*:node.js:*:* | 2.1.1 | Vulnerable | Spumko Project |
| cpe:2.3:a:spumko_project:hapi_server_framework:2.1.2:*:*:*:*:node.js:*:* | 2.1.2 | Vulnerable | Spumko Project |
- cpe:2.3:a:spumko_project:hapi_server_framework:2.0.0:-:*:*:*:node.js:*:* Versions 2.0.0 Vulnerable ·Spumko Project
- cpe:2.3:a:spumko_project:hapi_server_framework:2.0.0:preview:*:*:*:node.js:*:* Versions 2.0.0 preview Vulnerable ·Spumko Project
- cpe:2.3:a:spumko_project:hapi_server_framework:2.1.1:*:*:*:*:node.js:*:* Versions 2.1.1 Vulnerable ·Spumko Project
- cpe:2.3:a:spumko_project:hapi_server_framework:2.1.2:*:*:*:*:node.js:*:* Versions 2.1.2 Vulnerable ·Spumko Project
Remediation
- Fix · GHSA-cqr7-78pj-3g7j hapi (npm) Fixed in 2.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-3742
- 2026-10-03 Alias added: GHSA-cqr7-78pj-3g7j
References
Advisory 3
Sources
- CVE-2014-3742 · CVE Program
- CVE-2014-3742 · NVD
- FIRST EPSS
- GHSA-cqr7-78pj-3g7j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences