Injection in Ansible
Priority MEDIUM 50CWE-74Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
The safe_eval function in Ansible before 1.6.4 does not properly restrict the code subset, which allows remote attackers to execute arbitrary code via crafted instructions. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-4657.
Why it matters now
EPSS 0.05341 92nd percentileScored 2026-11-07
Fix Fixed Ansible: 1.6.4ansible (PyPI): 1.6.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | Ansible | before 1.6.4 | 1.6.4 | Patch available | CNA |
| — | ansible (PyPI) | before 1.6.4 | 1.6.4 | Patch available | GHSA-66c7-5pwv-mm3j |
- Ansible Vendor— Affected before 1.6.4 Fixed in 1.6.4 Patch available CNA
- ansible (PyPI) Vendor— Affected before 1.6.4 Fixed in 1.6.4 Patch available GHSA-66c7-5pwv-mm3j
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:* | before 1.6.4 | Vulnerable | Red Hat |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:redhat:ansible:*:*:*:*:*:*:*:* Versions before 1.6.4 Vulnerable ·Red Hat
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA Ansible Fixed in 1.6.4
- Fix · GHSA-66c7-5pwv-mm3j ansible (PyPI) Fixed in 1.6.4 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 8 products
- CloudForms Management Engine 5
- Red Hat Ansible Engine 2
- Red Hat Ansible Tower 3
- Red Hat Ceph Storage 2
- Red Hat Ceph Storage 3
- Red Hat OpenStack Platform 10 (Newton)
- Red Hat OpenStack Platform 13 (Queens)
- Red Hat Storage 3
Timeline
- 2026-10-02 Threatist record created from CVE-2014-4678
- 2026-10-03 Alias added: GHSA-66c7-5pwv-mm3j
References
Patch 3
Advisory 3
Sources
- CVE-2014-4678 · CVE Program
- CVE-2014-4678 · NVD
- FIRST EPSS
- GHSA-66c7-5pwv-mm3j · GitHub Advisory Database · CC BY 4.0
- CVE-2014-4678 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences