The lynx gem before 1.0.0 for Ruby places the configured password on command lines, which…
Priority LOW 35CWE-255Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
The lynx gem before 1.0.0 for Ruby places the configured password on command lines, which allows local users to obtain sensitive information by listing processes.
Why it matters now
EPSS 0.00522 44th percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD
Fix Fixed lynx (RubyGems): 1.0.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | lynx (RubyGems) | before 1.0.0 | 1.0.0 | Patch available | GHSA-94cq-7ccq-cmcm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- lynx (RubyGems) Vendor— Affected before 1.0.0 Fixed in 1.0.0 Patch available GHSA-94cq-7ccq-cmcm
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:lynx_project:lynx:*:*:*:*:*:ruby:*:* | before 1.0.0 | Vulnerable | Lynx Project |
- cpe:2.3:a:lynx_project:lynx:*:*:*:*:*:ruby:*:* Versions before 1.0.0 Vulnerable ·Lynx Project
Remediation
- Fix · GHSA-94cq-7ccq-cmcm lynx (RubyGems) Fixed in 1.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-5002
- 2026-10-03 Alias added: GHSA-94cq-7ccq-cmcm
References
Exploit 3
Advisory 2
More Lynx Project Lynx vulnerabilities
- TI-1999-01496 Lynx 2.x does not properly distinguish between internal and external HTML, which may… CVSS 3.1HIGH 7.8
- TI-2021-15844 Lynx through 2.8.9 mishandles the userinfo subcomponent of a URI, which allows remote… CVSS 3.1MEDIUM 5.3
- TI-2017-14529 Lynx before 2.8.9dev.16 is vulnerable to a use after free in the HTML parser resulting in… CVSS 3.0MEDIUM 5.3
Sources
- CVE-2014-5002 · CVE Program
- CVE-2014-5002 · NVD
- FIRST EPSS
- GHSA-94cq-7ccq-cmcm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences