schema.py in Roundup before 1.5.1 does not properly limit attributes included in default…
Priority LOW 23CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass, Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264 and CWE-200.
Summary
schema.py in Roundup before 1.5.1 does not properly limit attributes included in default user permissions, which might allow remote authenticated users to obtain sensitive user information by viewing user details.
Why it matters now
EPSS 0.01578 75th percentileScored 2026-11-07
Fix Fixed roundup (PyPI): 1.5.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | roundup (PyPI) | before 1.5.1 | 1.5.1 | Patch available | GHSA-j556-q367-2gw6 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- roundup (PyPI) Vendor— Affected before 1.5.1 Fixed in 1.5.1 Patch available GHSA-j556-q367-2gw6
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:roundup-tracker:roundup:*:*:*:*:*:*:*:* | up to 1.5.0 | Vulnerable | roundup-tracker |
| cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
- cpe:2.3:a:roundup-tracker:roundup:*:*:*:*:*:*:*:* Versions up to 1.5.0 Vulnerable ·roundup-tracker
- cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-j556-q367-2gw6 roundup (PyPI) Fixed in 1.5.1 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2014-6276
- 2026-10-03 Alias added: GHSA-j556-q367-2gw6
References
Sources
- CVE-2014-6276 · CVE Program
- CVE-2014-6276 · NVD
- FIRST EPSS
- GHSA-j556-q367-2gw6 · GitHub Advisory Database · CC BY 4.0
- CVE-2014-6276 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences