The Ajax dispatcher for Extbase in the Yet Another Gallery (yag) extension before 3.0.1…
Priority LOW 36CWE-264Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · Partial · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-264.
Summary
The Ajax dispatcher for Extbase in the Yet Another Gallery (yag) extension before 3.0.1 and Tools for Extbase development (pt_extbase) extension before 1.5.1 allows remote attackers to bypass access restrictions and execute arbitrary controller actions via unspecified vectors.
Why it matters now
EPSS 0.01523 74th percentileScored 2026-11-07
Fix Fixed dl/yag (Packagist): 3.0.1punktde/pt_extbase (Packagist): 1.5.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | dl/yag (Packagist) | before 3.0.1 | 3.0.1 | Patch available | GHSA-46fq-683f-2jwq |
| — | punktde/pt_extbase (Packagist) | before 1.5.1 | 1.5.1 | Patch available | GHSA-46fq-683f-2jwq |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- dl/yag (Packagist) Vendor— Affected before 3.0.1 Fixed in 3.0.1 Patch available GHSA-46fq-683f-2jwq
- punktde/pt_extbase (Packagist) Vendor— Affected before 1.5.1 Fixed in 1.5.1 Patch available GHSA-46fq-683f-2jwq
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:daniel_lienert:yet_another_gallery:*:*:*:*:*:typo3:*:* | up to 3.0.0 | Vulnerable | Daniel Lienert |
| cpe:2.3:a:michael_knoll:tools_for_extbase_developmen:*:*:*:*:*:typo3:*:* | up to 1.5.0 | Vulnerable | Michael Knoll |
- cpe:2.3:a:daniel_lienert:yet_another_gallery:*:*:*:*:*:typo3:*:* Versions up to 3.0.0 Vulnerable ·Daniel Lienert
- cpe:2.3:a:michael_knoll:tools_for_extbase_developmen:*:*:*:*:*:typo3:*:* Versions up to 1.5.0 Vulnerable ·Michael Knoll
Remediation
- Fix · GHSA-46fq-683f-2jwq dl/yag (Packagist) Fixed in 3.0.1 Advisory →
- Fix · GHSA-46fq-683f-2jwq punktde/pt_extbase (Packagist) Fixed in 1.5.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-6289
- 2026-10-03 Alias added: GHSA-46fq-683f-2jwq
References
Advisory 2
Other 5
- http://typo3.org/extensions/repository/view/yag
- http://typo3.org/extensions/repository/view/pt_extbase
- https://github.com/YAG-Gallery/yag/commit/4ab6ca121044d31b3822ab0c922053a9de8ee4ef
- https://github.com/punktDe/pt_extbase/commit/9969635830fcf5c3222de0fd9dc0d9a05f8d6cb1
- https://typo3.org/security/advisory/typo3-ext-sa-2014-005
Sources
- CVE-2014-6289 · CVE Program
- CVE-2014-6289 · NVD
- FIRST EPSS
- GHSA-46fq-683f-2jwq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences