The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a…
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 1 without a fix
Attack profile from CVSS 3.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
The Express web framework before 3.11 and 4.x before 4.5 for Node.js does not provide a charset field in HTTP Content-Type headers in 400 level responses, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via characters in a non-standard encoding.
Why it matters now
EPSS 0.01144 66th percentileScored 2026-11-07
Fix Partial express (npm): 3.11.0, 4.5.0Red Hat: 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | express (npm) | before 3.11.0 | 3.11.0 | Patch available | GHSA-gpvr-g6gh-9mc2 |
| — | express (npm) | 4.0.0 to before 4.5.0 | 4.5.0 | Patch available | GHSA-gpvr-g6gh-9mc2 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- express (npm) Vendor— Affected before 3.11.0 Fixed in 3.11.0 Patch available GHSA-gpvr-g6gh-9mc2
- express (npm) Vendor— Affected 4.0.0 to before 4.5.0 Fixed in 4.5.0 Patch available GHSA-gpvr-g6gh-9mc2
CPE configurations NVD · 15
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openjsf:express:*:*:*:*:*:*:*:* | up to 3.10.5 | Vulnerable | fast-uri |
| cpe:2.3:a:openjsf:express:4.0.0:*:*:*:*:*:*:* | 4.0.0 | Vulnerable | fast-uri |
| cpe:2.3:a:openjsf:express:4.1.0:*:*:*:*:*:*:* | 4.1.0 | Vulnerable | fast-uri |
| cpe:2.3:a:openjsf:express:4.1.1:*:*:*:*:*:*:* | 4.1.1 | Vulnerable | fast-uri |
| cpe:2.3:a:openjsf:express:4.1.2:*:*:*:*:*:*:* | 4.1.2 | Vulnerable | fast-uri |
| cpe:2.3:a:openjsf:express:4.2.0:*:*:*:*:*:*:* | 4.2.0 | Vulnerable | fast-uri |
| cpe:2.3:a:openjsf:express:4.3.0:*:*:*:*:*:*:* | 4.3.0 | Vulnerable | fast-uri |
| cpe:2.3:a:openjsf:express:4.3.1:*:*:*:*:*:*:* | 4.3.1 | Vulnerable | fast-uri |
| cpe:2.3:a:openjsf:express:4.3.2:*:*:*:*:*:*:* | 4.3.2 | Vulnerable | fast-uri |
| cpe:2.3:a:openjsf:express:4.4.0:*:*:*:*:*:*:* | 4.4.0 | Vulnerable | fast-uri |
- cpe:2.3:a:openjsf:express:*:*:*:*:*:*:*:* Versions up to 3.10.5 Vulnerable ·fast-uri
- cpe:2.3:a:openjsf:express:4.0.0:*:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·fast-uri
- cpe:2.3:a:openjsf:express:4.1.0:*:*:*:*:*:*:* Versions 4.1.0 Vulnerable ·fast-uri
- cpe:2.3:a:openjsf:express:4.1.1:*:*:*:*:*:*:* Versions 4.1.1 Vulnerable ·fast-uri
- cpe:2.3:a:openjsf:express:4.1.2:*:*:*:*:*:*:* Versions 4.1.2 Vulnerable ·fast-uri
- cpe:2.3:a:openjsf:express:4.2.0:*:*:*:*:*:*:* Versions 4.2.0 Vulnerable ·fast-uri
- cpe:2.3:a:openjsf:express:4.3.0:*:*:*:*:*:*:* Versions 4.3.0 Vulnerable ·fast-uri
- cpe:2.3:a:openjsf:express:4.3.1:*:*:*:*:*:*:* Versions 4.3.1 Vulnerable ·fast-uri
- cpe:2.3:a:openjsf:express:4.3.2:*:*:*:*:*:*:* Versions 4.3.2 Vulnerable ·fast-uri
- cpe:2.3:a:openjsf:express:4.4.0:*:*:*:*:*:*:* Versions 4.4.0 Vulnerable ·fast-uri
Show 5 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:openjsf:express:4.4.1:*:*:*:*:*:*:* | 4.4.1 | Vulnerable | fast-uri |
| cpe:2.3:a:openjsf:express:4.4.2:*:*:*:*:*:*:* | 4.4.2 | Vulnerable | fast-uri |
| cpe:2.3:a:openjsf:express:4.4.3:*:*:*:*:*:*:* | 4.4.3 | Vulnerable | fast-uri |
| cpe:2.3:a:openjsf:express:4.4.4:*:*:*:*:*:*:* | 4.4.4 | Vulnerable | fast-uri |
| cpe:2.3:a:openjsf:express:4.4.5:*:*:*:*:*:*:* | 4.4.5 | Vulnerable | fast-uri |
- cpe:2.3:a:openjsf:express:4.4.1:*:*:*:*:*:*:* Versions 4.4.1 Vulnerable ·fast-uri
- cpe:2.3:a:openjsf:express:4.4.2:*:*:*:*:*:*:* Versions 4.4.2 Vulnerable ·fast-uri
- cpe:2.3:a:openjsf:express:4.4.3:*:*:*:*:*:*:* Versions 4.4.3 Vulnerable ·fast-uri
- cpe:2.3:a:openjsf:express:4.4.4:*:*:*:*:*:*:* Versions 4.4.4 Vulnerable ·fast-uri
- cpe:2.3:a:openjsf:express:4.4.5:*:*:*:*:*:*:* Versions 4.4.5 Vulnerable ·fast-uri
Remediation
- Fix · GHSA-gpvr-g6gh-9mc2 express (npm) Fixed in 3.11.0 Advisory →
- Fix · GHSA-gpvr-g6gh-9mc2 express (npm) Fixed in 4.5.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Enterprise 2 | Affected | No fix planned: Will not fix |
Timeline
- 2026-10-02 Threatist record created from CVE-2014-6393
- 2026-10-03 Alias added: GHSA-gpvr-g6gh-9mc2
References
More fast-uri Express vulnerabilities
- TI-2022-08786 qs before 6.10.3, as used in Express before 4.17.3 and other products, allows attackers… CVSS 3.1HIGH 7.5
- TI-2024-09717 Preload arbitrary resources by injecting additional `Link` headers CVSS 3.1MEDIUM 5.3
- TI-2024-19223 Express.js Open Redirect in malformed URLs CVSS 3.1MEDIUM 6.1
- TI-2024-29390 express vulnerable to XSS via response.redirect() CVSS 3.1MEDIUM 5.0
Sources
- CVE-2014-6393 · CVE Program
- CVE-2014-6393 · NVD
- FIRST EPSS
- GHSA-gpvr-g6gh-9mc2 · GitHub Advisory Database · CC BY 4.0
- CVE-2014-6393 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences