Eval injection vulnerability in index.js in the syntax-error package before 1.1.1 for…
Priority MEDIUM 57CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Complete · Complete · Complete
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
Eval injection vulnerability in index.js in the syntax-error package before 1.1.1 for Node.js 0.10.x, as used in IBM Rational Application Developer and other products, allows remote attackers to execute arbitrary code via a crafted file.
Why it matters now
EPSS 0.13048 96th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed syntax-error (npm): 1.1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | syntax-error (npm) | before 1.1.1 | 1.1.1 | Patch available | GHSA-5726-g6r9-5f22 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- syntax-error (npm) Vendor— Affected before 1.1.1 Fixed in 1.1.1 Patch available GHSA-5726-g6r9-5f22
Remediation
- Fix · GHSA-5726-g6r9-5f22 syntax-error (npm) Fixed in 1.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-7192
- 2026-10-03 Alias added: GHSA-5726-g6r9-5f22
References
Exploit 1
Advisory 3
More Joyent Node.js vulnerabilities
- TI-2014-05260 visionmedia send before 0.8.4 for Node.js uses a partial comparison for verifying whether… CVSS 2.0HIGH 7.5
Sources
- CVE-2014-7192 · CVE Program
- CVE-2014-7192 · NVD
- FIRST EPSS
- GHSA-5726-g6r9-5f22 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences