The Crumb plugin before 3.0.0 for Node.js does not properly restrict token access in…
Priority LOW 29CWE-284Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Medium
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Partial · Partial · None
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-284.
Summary
The Crumb plugin before 3.0.0 for Node.js does not properly restrict token access in situations where a hapi route handler has CORS enabled, which allows remote attackers to obtain sensitive information, and potentially obtain the ability to spoof requests to non-CORS routes, via a crafted web site that is visited by an application consumer.
Why it matters now
EPSS 0.01367 72nd percentileScored 2026-11-07
Fix Fixed crumb (npm): 3.0.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | crumb (npm) | before 3.0.0 | 3.0.0 | Patch available | GHSA-84fq-6626-w5fg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- crumb (npm) Vendor— Affected before 3.0.0 Fixed in 3.0.0 Patch available GHSA-84fq-6626-w5fg
Remediation
- Fix · GHSA-84fq-6626-w5fg crumb (npm) Fixed in 3.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-7193
- 2026-10-03 Alias added: GHSA-84fq-6626-w5fg
References
Advisory 3
Sources
- CVE-2014-7193 · CVE Program
- CVE-2014-7193 · NVD
- FIRST EPSS
- GHSA-84fq-6626-w5fg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences