SQL injection vulnerability in Zend Framework before 1.12.9, 2.2.x before 2.2.8, and…
Priority MEDIUM 47CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
SQL injection vulnerability in Zend Framework before 1.12.9, 2.2.x before 2.2.8, and 2.3.x before 2.3.3, when using the sqlsrv PHP extension, allows remote attackers to execute arbitrary SQL commands via a null byte.
Why it matters now
EPSS 0.0255 85th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed zendframework/zendframework1 (Packagist): 1.12.9zendframework/zend-db (Packagist): 2.0.99, 2.1.99, 2.2.8 +1+1 more product
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | zendframework/zendframework1 (Packagist) | 1.12.0 to before 1.12.9 | 1.12.9 | Patch available | GHSA-qh9w-r7g5-q939 |
| — | zendframework/zend-db (Packagist) | 2.0.0 to before 2.0.99 | 2.0.99 | Patch available | GHSA-qh9w-r7g5-q939 |
| — | zendframework/zend-db (Packagist) | 2.1.0 to before 2.1.99 | 2.1.99 | Patch available | GHSA-qh9w-r7g5-q939 |
| — | zendframework/zend-db (Packagist) | 2.2.0 to before 2.2.8 | 2.2.8 | Patch available | GHSA-qh9w-r7g5-q939 |
| — | zendframework/zend-db (Packagist) | 2.3.0 to before 2.3.3 | 2.3.3 | Patch available | GHSA-qh9w-r7g5-q939 |
| — | zendframework/zendframework (Packagist) | 2.0.0 to before 2.0.99 | 2.0.99 | Patch available | GHSA-qh9w-r7g5-q939 |
| — | zendframework/zendframework (Packagist) | 2.1.0 to before 2.1.99 | 2.1.99 | Patch available | GHSA-qh9w-r7g5-q939 |
| — | zendframework/zendframework (Packagist) | 2.2.0 to before 2.2.8 | 2.2.8 | Patch available | GHSA-qh9w-r7g5-q939 |
| — | zendframework/zendframework (Packagist) | 2.3.0 to before 2.3.3 | 2.3.3 | Patch available | GHSA-qh9w-r7g5-q939 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- zendframework/zendframework1 (Packagist) Vendor— Affected 1.12.0 to before 1.12.9 Fixed in 1.12.9 Patch available GHSA-qh9w-r7g5-q939
- zendframework/zend-db (Packagist) Vendor— Affected 2.0.0 to before 2.0.99 Fixed in 2.0.99 Patch available GHSA-qh9w-r7g5-q939
- zendframework/zend-db (Packagist) Vendor— Affected 2.1.0 to before 2.1.99 Fixed in 2.1.99 Patch available GHSA-qh9w-r7g5-q939
- zendframework/zend-db (Packagist) Vendor— Affected 2.2.0 to before 2.2.8 Fixed in 2.2.8 Patch available GHSA-qh9w-r7g5-q939
- zendframework/zend-db (Packagist) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-qh9w-r7g5-q939
- zendframework/zendframework (Packagist) Vendor— Affected 2.0.0 to before 2.0.99 Fixed in 2.0.99 Patch available GHSA-qh9w-r7g5-q939
- zendframework/zendframework (Packagist) Vendor— Affected 2.1.0 to before 2.1.99 Fixed in 2.1.99 Patch available GHSA-qh9w-r7g5-q939
- zendframework/zendframework (Packagist) Vendor— Affected 2.2.0 to before 2.2.8 Fixed in 2.2.8 Patch available GHSA-qh9w-r7g5-q939
- zendframework/zendframework (Packagist) Vendor— Affected 2.3.0 to before 2.3.3 Fixed in 2.3.3 Patch available GHSA-qh9w-r7g5-q939
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:zend:zend_framework:*:*:*:*:*:*:*:* | before 1.12.9; 2.2.0 to before 2.2.8; 2.3.0 to before 2.3.3 | Vulnerable | Zend |
| cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* | 6.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* | 7.0 | Vulnerable | Red Hat |
| cpe:2.3:o:fedoraproject:fedora:19:*:*:*:*:*:*:* | 19 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:20:*:*:*:*:*:*:* | 20 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:21:*:*:*:*:*:*:* | 21 | Vulnerable | Fedoraproject |
- cpe:2.3:a:zend:zend_framework:*:*:*:*:*:*:*:* Versions before 1.12.9; 2.2.0 to before 2.2.8; 2.3.0 to before 2.3.3 Vulnerable ·Zend
- cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* Versions 6.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Vulnerable ·Red Hat
- cpe:2.3:o:fedoraproject:fedora:19:*:*:*:*:*:*:* Versions 19 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:20:*:*:*:*:*:*:* Versions 20 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:21:*:*:*:*:*:*:* Versions 21 Vulnerable ·Fedoraproject
Remediation
- Fix · GHSA-qh9w-r7g5-q939 zendframework/zendframework1 (Packagist) Fixed in 1.12.9 Advisory →
- Fix · GHSA-qh9w-r7g5-q939 zendframework/zend-db (Packagist) Fixed in 2.0.99 Advisory →
- Fix · GHSA-qh9w-r7g5-q939 zendframework/zend-db (Packagist) Fixed in 2.1.99 Advisory →
- Fix · GHSA-qh9w-r7g5-q939 zendframework/zend-db (Packagist) Fixed in 2.2.8 Advisory →
- Fix · GHSA-qh9w-r7g5-q939 zendframework/zend-db (Packagist) Fixed in 2.3.3 Advisory →
- Fix · GHSA-qh9w-r7g5-q939 zendframework/zendframework (Packagist) Fixed in 2.0.99 Advisory →
- Fix · GHSA-qh9w-r7g5-q939 zendframework/zendframework (Packagist) Fixed in 2.1.99 Advisory →
- Fix · GHSA-qh9w-r7g5-q939 zendframework/zendframework (Packagist) Fixed in 2.2.8 Advisory →
- Fix · GHSA-qh9w-r7g5-q939 zendframework/zendframework (Packagist) Fixed in 2.3.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2014-8089
- 2026-10-03 Alias added: GHSA-qh9w-r7g5-q939
References
Advisory 3
Other 4
- https://framework.zend.com/security/advisory/ZF2014-06
- https://github.com/FriendsOfPHP/security-advisories/blob/master/zendframework/zend-db/CVE-2014-8089.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/zendframework/zendframework/CVE-2014-8089.yaml
- https://github.com/FriendsOfPHP/security-advisories/blob/master/zendframework/zendframework1/CVE-2014-8089.yaml
Sources
- CVE-2014-8089 · CVE Program
- CVE-2014-8089 · NVD
- FIRST EPSS
- GHSA-qh9w-r7g5-q939 · GitHub Advisory Database · CC BY 4.0
- CVE-2014-8089 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences