The VMware driver in OpenStack Compute (Nova) before 2014.1.4 allows remote authenticated…
Priority LOW 23CWE-399Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Partial
- Fix status
- Partial Red Hat: 2 fixed, 1 without a fix
Attack profile from CVSS 2.0 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-399 and the CVSS impact.
Summary
The VMware driver in OpenStack Compute (Nova) before 2014.1.4 allows remote authenticated users to cause a denial of service (disk consumption) by deleting an instance in the resize state.
Why it matters now
EPSS 0.02022 81st percentileScored 2026-11-07
Fix Partial nova (PyPI): 12.0.0a0Red Hat: 2 advisoriesRed Hat: 2 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | nova (PyPI) | before 12.0.0a0 | 12.0.0a0 | Patch available | GHSA-g63p-mfcm-54c4 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- nova (PyPI) Vendor— Affected before 12.0.0a0 Fixed in 12.0.0a0 Patch available GHSA-g63p-mfcm-54c4
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:redhat:openstack:5.0:*:*:*:*:*:*:* | 5.0 | Vulnerable | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* | 6.0 | Running on | Red Hat |
| cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* | 7.0 | Running on | Red Hat |
| cpe:2.3:a:openstack:nova:*:*:*:*:*:*:*:* | 2014.1 to before 2014.1.4 | Vulnerable | OpenStack |
- cpe:2.3:a:redhat:openstack:5.0:*:*:*:*:*:*:* Versions 5.0 Vulnerable ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:6.0:*:*:*:*:*:*:* Versions 6.0 Running on ·Red Hat
- cpe:2.3:o:redhat:enterprise_linux:7.0:*:*:*:*:*:*:* Versions 7.0 Running on ·Red Hat
- cpe:2.3:a:openstack:nova:*:*:*:*:*:*:*:* Versions 2014.1 to before 2014.1.4 Vulnerable ·OpenStack
Remediation
- Fix · GHSA-g63p-mfcm-54c4 nova (PyPI) Fixed in 12.0.0a0 Advisory →
Red Hat 2 advisories
- RHSA-2015:0843 Released 2015-04-16 · Red Hat rating Importantopenstack-nova security, bug fix, and enhancement update
- Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7 openstack-nova-2014.1.4-3.el7ost, openstack-nova-api-2014.1.4-3.el7ost, openstack-nova-cells-2014.1.4-3.el7ost +12
- RHSA-2015:0844 Released 2015-04-16 · Red Hat rating Importantopenstack-nova security, bug fix, and enhancement update
- Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6 openstack-nova-2014.1.4-3.el6ost, openstack-nova-api-2014.1.4-3.el6ost, openstack-nova-cells-2014.1.4-3.el6ost +12
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenStack Platform 4 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 6 | Fixed | RHSA-2015:0844 |
| Red Hat Enterprise Linux OpenStack Platform 5.0 (Icehouse) for RHEL 7 | Fixed | RHSA-2015:0843 |
Timeline
- 2026-10-02 Threatist record created from CVE-2014-8333
- 2026-10-03 Alias added: GHSA-g63p-mfcm-54c4
References
Advisory 4
Sources
- CVE-2014-8333 · CVE Program
- CVE-2014-8333 · NVD
- FIRST EPSS
- GHSA-g63p-mfcm-54c4 · GitHub Advisory Database · CC BY 4.0
- CVE-2014-8333 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences