python-requests-Kerberos through 0.5 does not handle mutual authentication
Priority MEDIUM 48CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
python-requests-Kerberos through 0.5 does not handle mutual authentication
Why it matters now
EPSS 0.03647 89th percentileScored 2026-11-07
Fix Fixed requests-kerberos (PyPI): 0.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | requests-kerberos (PyPI) | before 0.6 | 0.6 | Patch available | GHSA-wh37-37xw-54hr |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- requests-kerberos (PyPI) Vendor— Affected before 0.6 Fixed in 0.6 Patch available GHSA-wh37-37xw-54hr
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:requests-kerberos_project:requests-kerberos:*:*:*:*:*:*:*:* | up to 0.5 | Vulnerable | Requests-kerberos Project |
| cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:requests-kerberos_project:requests-kerberos:*:*:*:*:*:*:*:* Versions up to 0.5 Vulnerable ·Requests-kerberos Project
- cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-wh37-37xw-54hr requests-kerberos (PyPI) Fixed in 0.6 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2014-8650
- 2026-10-03 Alias added: GHSA-wh37-37xw-54hr
References
Patch 3
Advisory 2
Other 6
- https://github.com/requests/requests-kerberos/issues/35
- https://github.com/requests/requests-kerberos/pull/36
- https://github.com/mkomitee/requests-kerberos/commit/9c1e08cc17bb6950455a85d33d391ecd2bce6eb6
- https://github.com/mkomitee/requests-kerberos
- https://github.com/pypa/advisory-database/tree/main/vulns/requests-kerberos/PYSEC-2019-200.yaml
- https://github.com/requests/requests-kerberos/blob/0.6/HISTORY.rst
Sources
- CVE-2014-8650 · CVE Program
- CVE-2014-8650 · NVD
- FIRST EPSS
- GHSA-wh37-37xw-54hr · GitHub Advisory Database · CC BY 4.0
- CVE-2014-8650 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences