Uncontrolled resource consumption in HackerOne qs node module
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-400.
Summary
The qs module before 1.0.0 does not have an option or default for specifying object depth and when parsing a string representing a deeply nested object will block the event loop for long periods of time. An attacker could leverage this to cause a temporary denial-of-service condition, for example, in a web application, other requests would not be processed while this blocking is occurring.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | qs node module | before 1.0.0 | 1.0.0 | Patch available | CNA |
| — | qs (npm) | before 1.0.0 | 1.0.0 | Patch available | GHSA-f9cm-p3w6-xvr3 |
- qs node module VendorHackerOne Affected before 1.0.0 Fixed in 1.0.0 Patch available CNA
- qs (npm) Vendor— Affected before 1.0.0 Fixed in 1.0.0 Patch available GHSA-f9cm-p3w6-xvr3
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:qs_project:qs:*:*:*:*:*:node.js:*:* | before 1.0.0 | Vulnerable | Qs Project |
- cpe:2.3:a:qs_project:qs:*:*:*:*:*:node.js:*:* Versions before 1.0.0 Vulnerable ·Qs Project
Remediation
- Fix · CNA qs node module (HackerOne) Fixed in 1.0.0
- Fix · GHSA-f9cm-p3w6-xvr3 qs (npm) Fixed in 1.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-10064
- 2026-10-03 Alias added: GHSA-f9cm-p3w6-xvr3
References
More Qs Project Qs vulnerabilities
- TI-2022-08786 qs before 6.10.3, as used in Express before 4.17.3 and other products, allows attackers… CVSS 3.1HIGH 7.5
- TI-2026-02026 qs's arrayLimit bypass in comma parsing allows denial of service CVSS 4.0MEDIUM 6.3
- TI-2017-14390 the web framework using ljharb's qs module older than v6.3.2, v6.2.3, v6.1.2, and v6.0.4… CVSS 3.0HIGH 7.5
- TI-2025-13959 arrayLimit bypass in bracket notation allows DoS via memory exhaustion CVSS 4.0MEDIUM 6.3
Sources
- CVE-2014-10064 · CVE Program
- CVE-2014-10064 · NVD
- FIRST EPSS
- GHSA-f9cm-p3w6-xvr3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences