Path traversal in HackerOne fancy-server node module
Priority LOW 36CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-22 and the CVSS impact.
Summary
Versions less than 0.1.4 of the static file server module fancy-server are vulnerable to directory traversal. An attacker can provide input such as `../` to read files outside of the served directory.
Why it matters now
EPSS 0.01582 75th percentileScored 2026-11-07
Fix Fixed fancy-server node module (HackerOne): 0.1.4fancy-server (npm): 0.1.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | fancy-server node module | before 0.1.4 | 0.1.4 | Patch available | CNA |
| — | fancy-server (npm) | before 0.1.4 | 0.1.4 | Patch available | GHSA-m273-wwfv-h6jp |
- fancy-server node module VendorHackerOne Affected before 0.1.4 Fixed in 0.1.4 Patch available CNA
- fancy-server (npm) Vendor— Affected before 0.1.4 Fixed in 0.1.4 Patch available GHSA-m273-wwfv-h6jp
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fancy-server_project:fancy-server:*:*:*:*:*:node.js:*:* | before 0.1.4 | Vulnerable | Fancy-server Project |
- cpe:2.3:a:fancy-server_project:fancy-server:*:*:*:*:*:node.js:*:* Versions before 0.1.4 Vulnerable ·Fancy-server Project
Remediation
- Fix · CNA fancy-server node module (HackerOne) Fixed in 0.1.4
- Fix · GHSA-m273-wwfv-h6jp fancy-server (npm) Fixed in 0.1.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-10066
- 2026-10-03 Alias added: GHSA-m273-wwfv-h6jp
References
Sources
- CVE-2014-10066 · CVE Program
- CVE-2014-10066 · NVD
- FIRST EPSS
- GHSA-m273-wwfv-h6jp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences