Improper authentication in HackerOne paypal-ipn node module
Priority LOW 29CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
paypal-ipn before 3.0.0 uses the `test_ipn` parameter (which is set by the PayPal IPN simulator) to determine if it should use the production PayPal site or the sandbox. With a bit of time, an attacker could craft a request using the simulator that would fool any application which does not explicitly check for test_ipn in production.
Why it matters now
EPSS 0.01129 66th percentileScored 2026-11-07
Fix Fixed paypal-ipn node module (HackerOne): 3.0.0paypal-ipn (npm): 3.0.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HackerOne | paypal-ipn node module | before 3.0.0 | 3.0.0 | Patch available | CNA |
| — | paypal-ipn (npm) | before 3.0.0 | 3.0.0 | Patch available | GHSA-h698-r4hm-w94p |
- paypal-ipn node module VendorHackerOne Affected before 3.0.0 Fixed in 3.0.0 Patch available CNA
- paypal-ipn (npm) Vendor— Affected before 3.0.0 Fixed in 3.0.0 Patch available GHSA-h698-r4hm-w94p
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:paypal-ipn_project:paypal-ipn:*:*:*:*:*:node.js:*:* | before 3.0.0 | Vulnerable | Paypal-ipn Project |
- cpe:2.3:a:paypal-ipn_project:paypal-ipn:*:*:*:*:*:node.js:*:* Versions before 3.0.0 Vulnerable ·Paypal-ipn Project
Remediation
- Fix · CNA paypal-ipn node module (HackerOne) Fixed in 3.0.0
- Fix · GHSA-h698-r4hm-w94p paypal-ipn (npm) Fixed in 3.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-10067
- 2026-10-03 Alias added: GHSA-h698-r4hm-w94p
References
Sources
- CVE-2014-10067 · CVE Program
- CVE-2014-10067 · NVD
- FIRST EPSS
- GHSA-h698-r4hm-w94p · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences