Read the docs

himiklab yii2-jqgrid-widget JqGridAction.php addSearchOptionsRecursively sql injection

Priority MEDIUM 43CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

A vulnerability was found in himiklab yii2-jqgrid-widget up to 1.0.7. It has been declared as critical. This vulnerability affects the function addSearchOptionsRecursively of the file JqGridAction.php. The manipulation leads to sql injection. Upgrading to version 1.0.8 is able to address this issue. The name of the patch is a117e0f2df729e3ff726968794d9a5ac40e660b9. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217564.

Why it matters now

EPSS 0.00752 55th percentileScored 2026-11-07
Fix Fixed himiklab/yii2-jqgrid-widget (Packagist): 1.0.8

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
himiklabyii2-jqgrid-widget1.0.0; 1.0.1; 1.0.2; 1.0.3; 1.0.4; 1.0.5; 1.0.6; 1.0.7—No fix listedCNA
—himiklab/yii2-jqgrid-widget (Packagist)before 1.0.81.0.8Patch availableGHSA-7mg5-rw39-q67f
  • yii2-jqgrid-widget Vendorhimiklab Affected 1.0.0; 1.0.1; 1.0.2; 1.0.3; 1.0.4; 1.0.5; 1.0.6; 1.0.7 Fixed in — No fix listed CNA
  • himiklab/yii2-jqgrid-widget (Packagist) Vendor— Affected before 1.0.8 Fixed in 1.0.8 Patch available GHSA-7mg5-rw39-q67f

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:yii2-jqgrid-widget_project:yii2-jqgrid-widget:*:*:*:*:*:*:*:*before 1.0.8VulnerableYii2-jqgrid-widget Project
  • cpe:2.3:a:yii2-jqgrid-widget_project:yii2-jqgrid-widget:*:*:*:*:*:*:*:* Versions before 1.0.8 Vulnerable ·Yii2-jqgrid-widget Project

Remediation

  • Fix · GHSA-7mg5-rw39-q67f himiklab/yii2-jqgrid-widget (Packagist) Fixed in 1.0.8 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2014-125051
  2. 2026-10-03 Alias added: GHSA-7mg5-rw39-q67f

References

Sources