agnivade easy-scrypt scrypt.go VerifyPassphrase timing discrepancy
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-208.
Summary
A vulnerability, which was classified as problematic, was found in agnivade easy-scrypt. Affected is the function VerifyPassphrase of the file scrypt.go. The manipulation leads to observable timing discrepancy. The complexity of an attack is rather high. The exploitability is told to be difficult. Upgrading to version 1.0.0 is able to address this issue. The name of the patch is 477c10cf3b144ddf96526aa09f5fdea613f21812. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-217596.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| agnivade | easy-scrypt | all versions | — | No fix listed | CNA |
| — | github.com/agnivade/easy-scrypt (Go) | before 1.0.0 | 1.0.0 | Patch available | GHSA-r894-5r7v-7rx3 |
- easy-scrypt Vendoragnivade Affected all versions Fixed in — No fix listed CNA
- github.com/agnivade/easy-scrypt (Go) Vendor— Affected before 1.0.0 Fixed in 1.0.0 Patch available GHSA-r894-5r7v-7rx3
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:easy-script_project:easy-script:*:*:*:*:*:*:*:* | before 1.0.0 | Vulnerable | Easy-script Project |
- cpe:2.3:a:easy-script_project:easy-script:*:*:*:*:*:*:*:* Versions before 1.0.0 Vulnerable ·Easy-script Project
Remediation
- Fix · GHSA-r894-5r7v-7rx3 github.com/agnivade/easy-scrypt (Go) Fixed in 1.0.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2014-125055
- 2026-10-03 Alias added: GHSA-r894-5r7v-7rx3
References
Sources
- CVE-2014-125055 · CVE Program
- CVE-2014-125055 · NVD
- FIRST EPSS
- GHSA-r894-5r7v-7rx3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences