Read the docs

I Recommend This Plugin dot-irecommendthis.php sql injection

Priority MEDIUM 43CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
High · High · High
Fix status
No fix listed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.

Summary

A vulnerability has been found in I Recommend This Plugin up to 3.7.2 on WordPress and classified as critical. Affected by this vulnerability is an unknown functionality of the file dot-irecommendthis.php. The manipulation leads to sql injection. The attack can be launched remotely. Upgrading to version 3.7.3 is able to address this issue. The identifier of the patch is 058b3ef5c7577bf557557904a53ecc8599b13649. It is recommended to upgrade the affected component. The identifier VDB-226309 was assigned to this vulnerability.

Why it matters now

EPSS 0.00723 54th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—I Recommend This Plugin3.7.0; 3.7.1; 3.7.2—No fix listedCNA
  • I Recommend This Plugin Vendor— Affected 3.7.0; 3.7.1; 3.7.2 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:themeist:i_recommend_this:*:*:*:*:*:wordpress:*:*up to 3.7.2VulnerableThemeist
  • cpe:2.3:a:themeist:i_recommend_this:*:*:*:*:*:wordpress:*:* Versions up to 3.7.2 Vulnerable ·Themeist

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2014-125099
  2. 2026-10-03 Alias added: GHSA-f6j6-4qcx-fq7v

References

  • TI-2014-08238 The i-recommend-this plugin before 3.7.3 for WordPress has SQL injection. CVSS 3.0CRITICAL 9.8
  • TI-2023-13213 WordPress I Recommend This Plugin <= 3.9.0 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2023-09487 WordPress I Recommend This Plugin <= 3.8.3 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9

Sources