Path traversal in NativeChurch WordPress theme exposes files
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA. Impact type from CWE-22 and the CVSS impact.
Summary
The NativeChurch theme for WordPress before 1.6.2 contains a path traversal flaw (CWE-22) in download.php. Unauthenticated remote attackers can send requests with directory traversal sequences to download arbitrary files, such as wp-config.php. The Shadowserver Foundation first observed exploitation on 2023-10-19, and a public exploit is linked in the references.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
NativeChurch theme for WordPress before 1.6.2 contains a path traversal vulnerability that allows unauthenticated attackers to download arbitrary files through the file parameter of download.php. Attackers can send GET requests with directory traversal sequences in the file parameter to retrieve sensitive files like wp-config.php. Exploitation evidence was first observed by the Shadowserver Foundation on 2023-10-19.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
Update the NativeChurch theme to version 1.6.2, the fixed version.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
- Fix · CNA NativeChurch (imithemes) Fixed in 1.6.2
Timeline
- 2026-10-20 Threatist record created from CVE-2014-125133
- 2026-10-21 Alias added: GHSA-r2vc-h8hf-99m9
- 2026-10-22 Priority changed: MEDIUM → LOW
- 2026-10-23 CISA SSVC decision points changed
- 2026-10-23 Priority changed: LOW → HIGH
References
Advisory 1
More imithemes vulnerabilities
- TI-2025-01978 IMITHEMES Listing <= 3.3 - Unauthenticated Privilege Escalation via Unverified Password Reset CVSS 3.1CRITICAL 9.8
- TI-2025-26223 WordPress Eventer plugin < 3.11.4 - SQL Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2025-06139 Improper privilege management in imithemes Real Spaces - WordPress Properties Directory… CVSS 3.1CRITICAL 9.8
- TI-2025-00814 Eventer - WordPress Event & Booking Manager Plugin <= 3.9.9.2 - Authenticated (Subscriber+) SQL Injection via reg_id CVSS 3.1HIGH 8.8
- TI-2025-07518 Improper privilege management in imithemes Real Spaces - WordPress Properties Directory… CVSS 3.1HIGH 8.8
- TI-2025-26224 WordPress Eventer plugin < 3.11.4 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2014-125133 · CVE Program
- CVE-2014-125133 · NVD
- FIRST EPSS
- GHSA-r2vc-h8hf-99m9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences