Read the docs
TI-2015-00191 Aliases CVE-2015-0219GHSA-7qfw-j7hp-v45g

Django before 1.4.18, 1.6.x before 1.6.10, and 1.7.x before 1.7.3 allows remote attackers…

Priority LOW 33CWE-17Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
— Not recorded in CVSS 2.0
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · Partial · None
Fix status
Fixed

Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-290.

Summary

Django before 1.4.18, 1.6.x before 1.6.10, and 1.7.x before 1.7.3 allows remote attackers to spoof WSGI headers by using an _ (underscore) character instead of a - (dash) character in an HTTP header, as demonstrated by an X-Auth_User header.

Why it matters now

EPSS 0.06969 94th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Django (PyPI): 1.4.18, 1.6.10, 1.7.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—Django (PyPI)before 1.4.181.4.18Patch availableGHSA-7qfw-j7hp-v45g
—Django (PyPI)1.6 to before 1.6.101.6.10Patch availableGHSA-7qfw-j7hp-v45g
—Django (PyPI)1.7 to before 1.7.31.7.3Patch availableGHSA-7qfw-j7hp-v45g
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • Django (PyPI) Vendor— Affected before 1.4.18 Fixed in 1.4.18 Patch available GHSA-7qfw-j7hp-v45g
  • Django (PyPI) Vendor— Affected 1.6 to before 1.6.10 Fixed in 1.6.10 Patch available GHSA-7qfw-j7hp-v45g
  • Django (PyPI) Vendor— Affected 1.7 to before 1.7.3 Fixed in 1.7.3 Patch available GHSA-7qfw-j7hp-v45g

CPE configurations NVD · 14

CPEVersionsRoleVendor
cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:*up to 1.4.17Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.6:*:*:*:*:*:*:*1.6Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.6.1:*:*:*:*:*:*:*1.6.1Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.6.2:*:*:*:*:*:*:*1.6.2Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.6.3:*:*:*:*:*:*:*1.6.3Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.6.4:*:*:*:*:*:*:*1.6.4Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.6.5:*:*:*:*:*:*:*1.6.5Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.6.6:*:*:*:*:*:*:*1.6.6Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.6.7:*:*:*:*:*:*:*1.6.7Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.6.8:*:*:*:*:*:*:*1.6.8Vulnerabledjangoproject
  • cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions up to 1.4.17 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.6:*:*:*:*:*:*:* Versions 1.6 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.6.1:*:*:*:*:*:*:* Versions 1.6.1 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.6.2:*:*:*:*:*:*:* Versions 1.6.2 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.6.3:*:*:*:*:*:*:* Versions 1.6.3 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.6.4:*:*:*:*:*:*:* Versions 1.6.4 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.6.5:*:*:*:*:*:*:* Versions 1.6.5 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.6.6:*:*:*:*:*:*:* Versions 1.6.6 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.6.7:*:*:*:*:*:*:* Versions 1.6.7 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.6.8:*:*:*:*:*:*:* Versions 1.6.8 Vulnerable ·djangoproject
Show 4 more CPE
CPEVersionsRoleVendor
cpe:2.3:a:djangoproject:django:1.6.9:*:*:*:*:*:*:*1.6.9Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.7:*:*:*:*:*:*:*1.7Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.7.1:*:*:*:*:*:*:*1.7.1Vulnerabledjangoproject
cpe:2.3:a:djangoproject:django:1.7.2:*:*:*:*:*:*:*1.7.2Vulnerabledjangoproject
  • cpe:2.3:a:djangoproject:django:1.6.9:*:*:*:*:*:*:* Versions 1.6.9 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.7:*:*:*:*:*:*:* Versions 1.7 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.7.1:*:*:*:*:*:*:* Versions 1.7.1 Vulnerable ·djangoproject
  • cpe:2.3:a:djangoproject:django:1.7.2:*:*:*:*:*:*:* Versions 1.7.2 Vulnerable ·djangoproject

Remediation

  • Fix · GHSA-7qfw-j7hp-v45g Django (PyPI) Fixed in 1.4.18 Advisory →
  • Fix · GHSA-7qfw-j7hp-v45g Django (PyPI) Fixed in 1.6.10 Advisory →
  • Fix · GHSA-7qfw-j7hp-v45g Django (PyPI) Fixed in 1.7.3 Advisory →

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

Not affected: 4 products
  • Red Hat Enterprise Linux OpenStack Platform 5 (Icehouse)
  • Red Hat Enterprise Linux OpenStack Platform 6 (Juno)
  • Red Hat OpenStack Platform 4
  • Red Hat Subscription Asset Manager

Timeline

  1. 2026-10-02 Threatist record created from CVE-2015-0219
  2. 2026-10-03 Alias added: GHSA-7qfw-j7hp-v45g

References

  • TI-2022-15177 An issue was discovered in Django 3.2 before 3.2.14 and 4.0 before 4.0.6. CVSS 3.1CRITICAL 9.8
  • TI-2020-05994 Django 1.11 before 1.11.28, 2.2 before 2.2.10, and 3.0 before 3.0.3 allows SQL Injection… CVSS 3.1CRITICAL 9.8
  • TI-2023-10198 An issue was discovered in the Multipart Request Parser in Django 3.2 before 3.2.18, 4.0… CVSS 3.1HIGH 7.5
  • TI-2019-14306 Django before 1.11.27, 2.x before 2.2.9, and 3.x before 3.0.1 allows account takeover. CVSS 3.1CRITICAL 9.8
  • TI-2019-10595 An issue was discovered in Django 1.11.x before 1.11.23, 2.1.x before 2.1.11, and 2.2.x… CVSS 3.0CRITICAL 9.8
  • TI-2021-14006 Django 3.1.x before 3.1.13 and 3.2.x before 3.2.5 allows QuerySet.order_by SQL injection… CVSS 3.1CRITICAL 9.8
See all 156 →

Sources