The django.views.static.serve view in Django before 1.4.18, 1.6.x before 1.6.10, and…
Priority LOW 30CWE-399Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- — Not recorded in CVSS 2.0
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Partial
- Fix status
- Fixed
Attack profile from CVSS 2.0 · NVD. Fix status from CNA and GitHub. Impact type from CWE-399 and the CVSS impact.
Summary
The django.views.static.serve view in Django before 1.4.18, 1.6.x before 1.6.10, and 1.7.x before 1.7.3 reads files an entire line at a time, which allows remote attackers to cause a denial of service (memory consumption) via a long line in a file.
Why it matters now
EPSS 0.04454 91st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Django (PyPI): 1.4.18, 1.6.10, 1.7.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | Django (PyPI) | before 1.4.18 | 1.4.18 | Patch available | GHSA-jhjg-w2cp-5j44 |
| — | Django (PyPI) | 1.6 to before 1.6.10 | 1.6.10 | Patch available | GHSA-jhjg-w2cp-5j44 |
| — | Django (PyPI) | 1.7 to before 1.7.3 | 1.7.3 | Patch available | GHSA-jhjg-w2cp-5j44 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- Django (PyPI) Vendor— Affected before 1.4.18 Fixed in 1.4.18 Patch available GHSA-jhjg-w2cp-5j44
- Django (PyPI) Vendor— Affected 1.6 to before 1.6.10 Fixed in 1.6.10 Patch available GHSA-jhjg-w2cp-5j44
- Django (PyPI) Vendor— Affected 1.7 to before 1.7.3 Fixed in 1.7.3 Patch available GHSA-jhjg-w2cp-5j44
CPE configurations NVD · 18
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* | up to 1.4.17 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.6:*:*:*:*:*:*:* | 1.6 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.6.1:*:*:*:*:*:*:* | 1.6.1 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.6.2:*:*:*:*:*:*:* | 1.6.2 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.6.3:*:*:*:*:*:*:* | 1.6.3 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.6.4:*:*:*:*:*:*:* | 1.6.4 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.6.5:*:*:*:*:*:*:* | 1.6.5 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.6.6:*:*:*:*:*:*:* | 1.6.6 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.6.7:*:*:*:*:*:*:* | 1.6.7 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.6.8:*:*:*:*:*:*:* | 1.6.8 | Vulnerable | djangoproject |
- cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:* Versions up to 1.4.17 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.6:*:*:*:*:*:*:* Versions 1.6 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.6.1:*:*:*:*:*:*:* Versions 1.6.1 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.6.2:*:*:*:*:*:*:* Versions 1.6.2 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.6.3:*:*:*:*:*:*:* Versions 1.6.3 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.6.4:*:*:*:*:*:*:* Versions 1.6.4 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.6.5:*:*:*:*:*:*:* Versions 1.6.5 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.6.6:*:*:*:*:*:*:* Versions 1.6.6 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.6.7:*:*:*:*:*:*:* Versions 1.6.7 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.6.8:*:*:*:*:*:*:* Versions 1.6.8 Vulnerable ·djangoproject
Show 8 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:djangoproject:django:1.6.9:*:*:*:*:*:*:* | 1.6.9 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.7:*:*:*:*:*:*:* | 1.7 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.7.1:*:*:*:*:*:*:* | 1.7.1 | Vulnerable | djangoproject |
| cpe:2.3:a:djangoproject:django:1.7.2:*:*:*:*:*:*:* | 1.7.2 | Vulnerable | djangoproject |
| cpe:2.3:o:canonical:ubuntu_linux:10.04:*:lts:*:*:*:*:* | 10.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:12.04:*:lts:*:*:*:*:* | 12.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* | 14.04 | Vulnerable | Canonical |
| cpe:2.3:o:canonical:ubuntu_linux:14.10:*:*:*:*:*:*:* | 14.10 | Vulnerable | Canonical |
- cpe:2.3:a:djangoproject:django:1.6.9:*:*:*:*:*:*:* Versions 1.6.9 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.7:*:*:*:*:*:*:* Versions 1.7 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.7.1:*:*:*:*:*:*:* Versions 1.7.1 Vulnerable ·djangoproject
- cpe:2.3:a:djangoproject:django:1.7.2:*:*:*:*:*:*:* Versions 1.7.2 Vulnerable ·djangoproject
- cpe:2.3:o:canonical:ubuntu_linux:10.04:*:lts:*:*:*:*:* Versions 10.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:12.04:*:lts:*:*:*:*:* Versions 12.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:* Versions 14.04 Vulnerable ·Canonical
- cpe:2.3:o:canonical:ubuntu_linux:14.10:*:*:*:*:*:*:* Versions 14.10 Vulnerable ·Canonical
Remediation
- Fix · GHSA-jhjg-w2cp-5j44 Django (PyPI) Fixed in 1.4.18 Advisory →
- Fix · GHSA-jhjg-w2cp-5j44 Django (PyPI) Fixed in 1.6.10 Advisory →
- Fix · GHSA-jhjg-w2cp-5j44 Django (PyPI) Fixed in 1.7.3 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux OpenStack Platform 5 (Icehouse)
- Red Hat Enterprise Linux OpenStack Platform 6 (Juno)
- Red Hat OpenStack Platform 4
- Red Hat Subscription Asset Manager
Timeline
- 2026-10-02 Threatist record created from CVE-2015-0221
- 2026-10-03 Alias added: GHSA-jhjg-w2cp-5j44
References
Patch 1
Advisory 8
Other 13
- http://advisories.mageia.org/MGASA-2015-0026.html
- https://github.com/django/django/commit/553779c4055e8742cc832ed525b9ee34b174934f
- https://github.com/django/django/commit/818e59a3f0fbadf6c447754d202d88df025f8f2a
- https://github.com/django/django/commit/d020da6646c5142bc092247d218a3d1ce3e993f7
- https://github.com/django/django
- https://github.com/django/django/blob/9b9c805cedb08621bd5dc58a01a6478eb7cc49a9/docs/releases/1.4.18.txt#L48C1-L49C1
- https://github.com/pypa/advisory-database/tree/main/vulns/django/PYSEC-2015-6.yaml
- https://web.archive.org/web/20150128111656/http://secunia.com/advisories/62285
- https://web.archive.org/web/20150128111656/http://secunia.com/advisories/62309
- https://web.archive.org/web/20150523054951/http://www.mandriva.com/en/support/security/advisories/advisory/MDVSA-2015:109/?name=MDVSA-2015:109
- https://web.archive.org/web/20150523054953/http://www.mandriva.com/en/support/security/advisories/advisory/MDVSA-2015:036/?name=MDVSA-2015:036
- https://web.archive.org/web/20151104201446/http://secunia.com/advisories/62718
- https://www.djangoproject.com/weblog/2015/jan/13/security
Sources
- CVE-2015-0221 · CVE Program
- CVE-2015-0221 · NVD
- FIRST EPSS
- GHSA-jhjg-w2cp-5j44 · GitHub Advisory Database · CC BY 4.0
- CVE-2015-0221 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences